Troubleshooting
Problem
Excel hangs and an error message is generated when running a form as a report.
Symptom
Standard Error
Source: ControllerForms
Description: The server threw an exception. (Exception from HRESULT: 0x80010105 (RPC_E_SERVERFAULT))
Cause
There are several potential causes for the "(Exception from HRESULT: 0x80010105 (RPC_E_SERVERFAULT))" error.
- For more examples, see separate IBM Technote #1574387.
This Technote specifically deals with the scenario where the client device is running a version of Microsoft Excel without required Microsoft patching applied.
- For an example of symptoms of incorrect patch levels, see separate IBM Technote #1394945.
Resolving The Problem
Ensure a compatible version of Excel is installed on client device.
For example:
- Excel 2003 - Requires Microsoft Office 2003 Service Pack 3
- Excel 2007 - Requires both of the following to be installed:
- Microsoft Office 2007 Service Pack 2
- Microsoft Office 2007 hotfix 974992
Related Information
[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.5.1;8.5;8.4;8.3","Edition":"Not Applicable","Line of Business":{"code":"LOB10","label":"Data and AI"}}]
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Document Information
Modified date:
15 June 2018
UID
swg21386072