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Error 'RSV-BBP-0022 - The absolute affinity request 'asynchWait_Request' failed' when trying to view some standard reports

Troubleshooting


Problem

User runs a Controller 'standard report' (also known as a 'system report'). A web page appears. The user expects that the report should soon appear. However, after a few seconds delay, an error message appears.

Symptom


RSV-BBP-0022
 The absolute affinity request 'asynchWait_Request' failed, the requested session does not exist.
 
Details
DPR-ERR-2082 An error has occurred. Please contact your administrator. The complete error has been logged by CAF with SecureErrorID:2009-05-08-10:19:27.702-#4

Cause

Controller 'standard reports' are powered by a Cognos 8 BI reporting engine. The error message is triggered because there is a problem with this Cognos 8 BI reporting engine communicating to the end user's Microsoft Internet Explorer session.

There are many different potential causes/solution. In most causes, the error is caused because a long-running report has timed out.

    MORE INFO Reports that run for more then 7 seconds enter an "asynchronous communication" mode. In this mode, the session sends periodic "wait()" requests to retrieve the data. If this request is not received for over 30 seconds (= the default async timeout) due to delays in the architecture, the dispatcher closes the session. This error is generated when the dispatcher then receives the "wait" request for the closed session. For a full explanation of this process, refer to separate IBM Technote #1340993.

There are several potential root causes for this timeout, and they include the following:

Scenario #1 - The report server is overloaded, because the recommended hardware specifications have not been met
  • See separate IBM Technotes #1340994 & 1339581 for more details

Scenario #2 - Firewall is interfering with communication between the client and the report server
  • See IBM Technote #1340994

Scenario #3 - Three (3) or more browser sessions are being used on the same client device simultaneously
  • See IBM Technote #1340994

Scenario #4 - Network connection between client device and Report server is slow
  • For example, there is a poor-quality wireless network or WAN connection
  • See IBM Technote #1344573.

TIP: Although timeouts are the most common cause, there are other possible causes such as:
  • Scenario #5 - The hostname specified for the server contains an '_' (underscore).
    • Windows (for example IIS) does not support underscore characters in many of its operations. It is therefore not a supported/recommended character
    • For more information, see separate IBM Technotes #1340388 , #1364707.

Resolving The Problem

Solution

Review the Technotes referred to inside the scenarios above. Resolve any issues that are found with your system.

Workaround - for timeout related problems

Increase the Cognos 8 async timeout parameter, to reduce the chance of a timeout

  • For example, increase the timeout from the default (30 seconds) to something larger (for example 60 or 90 seconds)

Steps for workaround:

See IBM Technote #1344573 for complete details, but to summarise:

  1. Obtain a short period of downtime (no users logged into the Cognos system)
  2. Logon to your Controller application server
  3. Open the folder ...\WEB-INF\services. TIP: By default, this is located here: C:\Program Files\cognos\c8\webapps\p2pd\WEB-INF\services
  4. Locate the file 'reportservice.xml'
  5. As a precaution, create a backup copy of this file
  6. Open the file reportservice.xml inside NOTEPAD.EXE
  7. Locate the section which refers to async_wait_timeout_ms
  8. Modify the setting to increase the timeout from the default (30 seconds = 30000ms) to a larger setting (for example 90 seconds = 90000 ms, or perhaps 60 seconds)
  9. Save the file
  10. Restart the Cognos 8 service (or the entire application server if preferred)
  11. Test

TIP: For example, the new setting will look similar to:


<param-name>async_wait_timeout_ms</param-name>
<param-value>90000</param-value>


[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.5;8.4;8.3","Edition":"Not Applicable","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21385378