IBM Support

404 - Not Found - New IBM Cognos BI installation can't open report studio

Troubleshooting


Problem

Brand new installation of IBM Cognos BI doesn't allow to open report studio. You get an error everytime. The issue does not happen if you use the dispatcher.

Symptom

The web request failed.
404 - Not Found
URL: http://localhost/cognos/pat/../schemas/rspec/X.x/V5_report.dtd

-------------------
The web request failed.
404 - Not Found
URL: http://localhost/cognos/pat/../schemas/rspec/X.x/V5_richText.dtd

Cause

URLscan is being used and is not allowing the URL for report studio to be used due to a "."

Environment

Windows 2003Windows server 2012

Resolving The Problem

Run the URLscan utility (typically attached to IIS)
- Navigate to ..\Windows\System32\inetsrv\urlscan\urlscan.ini
- Modify the .ini parameter 'AllowDotsInPath' to a value of 1. (Default is 0)
- Save file

**Restart the 'IIS Admin' service on the gateway machine
- Only restarting the 'Worldwide Web Publishing' will not be sufficient.

[{"Product":{"code":"SSEP7J","label":"Cognos Business Intelligence"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Cognos Connection","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.2;10.2.1;10.2.1.1;10.2.2","Edition":"All Editions","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Historical Number

1042368

Document Information

Modified date:
15 June 2018

UID

swg21382354