IBM Support

Changing Configured Database, Password, and Server names in Maximo Asset Management

Question & Answer


Question

Outline for performing v7 database name, password or server name changes.

Cause

While installing 7.1.1.4 update on a 7.1.0 system, gets error.
Error: CTGIN0158E: Cannot connect to "database" with userid "maximo"

System was originally pointing to another database and now has changed, but according to the log file the old database name is still being picked up.

Answer

The installation properties are maintained in the Maximo database, and in the maximo.properties file. These are required for Fix Pack and Interim Fix installations, and other product installations. Over time, passwords may change, hostnames/IP addresses or database names may change. In order to update these values, follow these instructions:

1. Update the \ibm\SMP\maximo\applications\maximo\properties\maximo.properties file on the Admin Workstation to change the IP-Address/Hostname for either the database server or the webserver. Also to update the password
a. Delete the file named maximo.properties
b. Rename the file named maximo.properties_orig to maximo.properties (this is an unencrypted file)
c. Edit the maximo.properties file and update the hostname/IP-address for the database server.
d. If necessary, update the password for the user to access the database
e. Save the file
Note: The file will be automatically re-encrypted when you install a fixpack or other product. If this is not an immediate activity, you can run encryptproperties.bat file located in C:\ibm\smp\maximo\tools\maximo directory against the file to encrypt it.
2. Update the \ibm\SMP\etc\install.properties file on the Admin Workstation to change the IP-Address/Hostname for either the database server or the webserver.
3. Update the values in the maximo database to change the IP-Address/Hostname for a variety of servers, or to update passwords.
a. Connect to the maximo database using your favorite SQL editor utility.
b. Query the maxpropvalue table, and find the key you need to edit. For example, WAS.DeploymentManagerHostName is the key for the hostname or IP address of the WebSphere machine.
c. Create a query to update that value to the new value, and run the query.
d. Repeat for any passwords, ip addresses etc that need to be updated.
4. Rebuild and redeploy the EAR files.

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSLKT6","label":"IBM Maximo Asset Management"},"Component":"Not Applicable","Platform":[],"Version":"All Versions","Edition":"All Editions","Line of Business":{"code":"LOB59","label":"Sustainability Software"}},{"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Product":{"code":"SSWT9A","label":"IBM Control Desk"},"Component":"Not Applicable","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
12 February 2020

UID

swg21382026