Compatibility error, updating product is not allowed, when applying Fix Pack to Rational Team products

Technote (troubleshooting)


Problem(Abstract)

This technote explains how to resolve a compatibility error such as "Updating ClearCase 7.1.0.01 is not allowed". This can occur when upgrading any IBM Rational Team product with a FixPack.

Symptom

Here is an example of the full error message:

Updating ClearCase 7.1.0.01 is not allowed; it is not compatible with IBM Rational ClearQuest 7.1

Variants of this error could be:

This package group is not compatible with ClearCase 7.1.0.01. It may be deployed in a different package group.  

Or...

You are trying to install ClearQuest 7.1 on a machine that has ClearCase at 7.1.0.01.  You need to either rollback to 7.1 or make all repositories available.

The error message might reference another Rational product instead of (or in addition to) ClearCase, such as RequisitePro.



Cause

This is working as designed. You must update all of the Rational Team products installed on your computer to the same or compatible Fix Pack level. These include the following programs:

  • ClearCase and ClearCase Remote Client (CCRC)
  • ClearQuest
  • License Server
  • RequisitePro
  • ProjectConsole
  • Robot
  • SoDA
  • TestManager

The repositories for the original, base product installations must also be available to IBM Installation Manager at the time of upgrade.

Resolving the problem

Establish repositories for the applicable Fix Pack for each Rational Team product installed. For example, you have ClearQuest 7.1.1, ClearCase 7.1.1, and ProjectConsole 7.0.3 installed. If you want to upgrade ClearQuest to version 7.1.1.1, you must also upgrade to version 7.1.1.1 for ClearCase and 7.0.3.1 for ProjectConsole.

Here is another example, with a screenshot of Installation Manager when applying these Fix Packs. The first two repositories are connections to the base installation files for ClearQuest and ClearCase 7.1. The next two are connections to the 7.1.0.1 Fix Packs for the two programs.



Notes:

  • The Fix Pack download page for your applicable product release will have details on which releases of the Team products are compatible with each other. For example, the latest ClearQuest Fix Pack download pages are listed in technote 1306624.
  • Rational TestManager is no longer available with the Rational Team products after version 7.0.2.x. You cannot upgrade to version 7.1.1/7.0.3 if the stand-alone Rational TestManager is installed. See technote 1375824 for more information.

Related information

ERROR: Failed to find all installation files

Cross Reference information
Segment Product Component Platform Version Edition
Software Development Rational ClearCase Installation 7.1, 7.1.1, 7.1.2
Software Development Rational RequisitePro Installation 7.1, 7.1.1, 7.1.2
Software Development Rational ProjectConsole Installation 7.0.2, 7.0.3, 7.0.4
Software Development Rational Robot Installation 7.0.2, 7.0.3
Software Development Rational SoDA Installation 7.0.2, 7.0.3, 7.0.4
Software Development Rational TestManager Installation 7.0.2
Software Development Rational Common Licensing Installation 7.1, 7.1.1, 8.1.1
Software Development Rational ClearCase ClearCase Remote Client 7.1, 7.1.1, 7.1.2

Rate this page:

(0 users)Average rating

Document information


More support for:

Rational ClearQuest
Installation

Software version:

7.1, 7.1.1, 7.1.2

Operating system(s):

AIX, HP-UX, Linux, Solaris, Windows

Reference #:

1381702

Modified date:

2010-04-28

Translate my page

Machine Translation

Content navigation