Technote (troubleshooting)
Problem
Running Xmlaccess with "ExportAllUsers.xml" as the input fails with the following exceptions:
<status element="[portal]" result="failed">
<message id="EJPXA0017E">com.ibm.wps.command.xml.XmlCommandException: EJPXA0017E: An error occurred while retrieving all user resources. [portal]</message>
<message id="EJPEB0003E">com.ibm.wps.command.CommandFailedException: EJPEB0003E: FindUserCommand.execute: An exception occurred.
WrappedException is: com.ibm.portal.puma.SizeLimitExceededException: EJPSG0015E: Data Backend Problem com.ibm.websphere.wim.exception.MaxResultsExceededException: CWWIM1018E '10000' search results exceeds the '4500' maximum search limit.</message>
<message id="EJPSG0015E">com.ibm.portal.puma.SizeLimitExceededException: EJPSG0015E: Data Backend Problem com.ibm.websphere.wim.exception.MaxResultsExceededException: CWWIM1018E '10000' search results exceeds the '4500' maximum search limit.</message>
<message>com.ibm.websphere.wim.exception.MaxResultsExceededException: CWWIM1018E '10000' search results exceeds the '4500' maximum search limit.</message>
</status>
Symptom
The SystemOut.log contains the following message:
com.ibm.websphere.wim.exception.MaxResultsExceededException:
CWWIM1018E '10000' search results exceeds the '4500' maximum search limit.
Similar exceptions can also occur when using the Manage Users and Groups portlet.
Cause
The maxSearchResults value in the wimconfig.xml file is smaller than the number of users/groups in user registry.
Resolving the problem
Increase the maximum search results that Virtual Member Manager (VMM) will return by updating the maxSearchResults property (default 4500) to a larger value such as 50,000) in the <wp_profile_root>/config/cells/<cellname>/wimconfig.xml file. Then restart the Portal server and retest the export.
NOTE: LDAP servers such as the Tivoli Directory Server may have a default slapd sizelimit. This limit can also cause XMLaccess and/or the Manage Users and Groups portlet search to fail. To check the limit, you can use the RootDSE output from the following command:
-
ldapsearch -h <ldaphost> -p 389 -b "" -s base objectclass=*
Consult with your LDAP administrator as needed to reset the parameter in the LDAP configuration.
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