Technote (troubleshooting)
Problem(Abstract)
Certain XML Provisioning requests can fail if WebSphere Voice Response is started automatically, for example by HACMP, or if WebSphere Voice Response was running before a system shutdown.
Cause
Some provisioning requests rely on the PATH environment being set correctly at WebSphere Voice Response startup. If this path is set up in the .profile of dtuser, provisioning requests work only if WebSphere Voice Response is started manually by logging in as dtuser. HACMP or automatic restart does not execute the dtuser .profile, and so the PATH is not set up correctly.
Resolving the problem
Ensure the required PATH is always set by adding the following line to the .vaeprofile.user file in the $VAE/sw/environ directory:
PATH=$PATH:/usr/lpp/dirTalk/db/current_dir/ca/IMC_Admin_dir/utils
Add this at the end of the file, in the section that starts with the following line:
# User area starts after this line do not delete this line
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