Technote (FAQ)
Question
Why does the error: "file DB2APP.dll cannot be found" occur?
Cause
The error occurs because of problems with the installation procedure.
Answer
The only way to resolve this is to manually un-install the various components that make up Tivoli Directory Server 4.3 and then re-install the product:
- Un-install Telelogic Directory Administration 4.3
- Un-install IBM Tivoli Directory Server if it is displayed
Do NOT un-install DB2 - Reboot the server and delete the registry keys:
- HKEY_LOCAL_MACHINE\SOFTWARE\Telelogic\TDS
- HKEY_LOCAL_MACHINE\SOFTWARE\IBM
- Re-install Tivoli Directory Server
At the end of installation, there shouldn't be any FATAL ERROR in the TDS_4.3_InstallLog.log file.
| Segment | Product | Component | Platform | Version | Edition |
|---|---|---|---|---|---|
| Software Development | Telelogic DOORS | Directory Server | Windows | ||
| Software Development | Telelogic DOORS Analyst | Installation | Windows | ||
| Software Development | Telelogic DOORS Net | Installation | Windows | ||
| Software Development | Telelogic DOORS Web Access | Directory Server | Windows | ||
| Software Development | Telelogic Change | Directory Server | Windows |
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