IBM Support

Unable to execute report: RSV-CM-0005

Troubleshooting


Problem

A Report Studio report fails with an error

Symptom

RSV-CM-0005 Content Manager did not return an object for the requested search path '/content/folder[@name='Foldername']/report[@name='Reportname']'

Cause

The reports were moved to a different location and the reports contain layout references. Because of this, the search path to the layout reference is broken.

Resolving The Problem

Edit the affected report and re-set the layout reference to the correct report.

  • Open the affected report
  • Select the layout reference element
  • Click on the property 'Component reference'
  • Select the report which contains the referenced layout element

[{"Product":{"code":"SSEP7J","label":"Cognos Business Intelligence"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Report Studio","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"10.2.2;10.2.1;10.2","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21371042