IBM Support

Unable to run trigger.bat command from the command line if not system administrator

Troubleshooting


Problem

Users that are not a member of system administrators role are not able to run trigger.bat command from the command line. Only users under system administrators role are able to run the trigger.bat command.

Symptom

AxisFault
faultCode: {'http://schemas.xmlsoap.org/soap/envelope/'}Client
faultSubcode: faultString: CNC-BAL-0503 The Client has failed.
faultActor:
faultNode:
faultDetail:
{'http://developer.cognos.com/schemas/bibus/3/'}exception:
<ns1:severity>error</ns1:severity>
<ns1:errorCode>CNC-BAL-0502 Error Number: 3402</ns1:errorCode>
<ns1:message>
<ns1:messageString>CNC-SEC-3402 Security Error: The current user does not have the necessary privileges for the request.</ns1:messageString>
<ns1:nestingLevel>0</ns1:nestingLevel>
</ns1:message>
CNC-BAL-0503 The Client has failed.
at org.apache.axis.message.SOAPFaultBuilder.createFault(SOAPFaultBuilder.java:260)
at org.apache.axis.message.SOAPFaultBuilder.endElement(SOAPFaultBuilder.java:169)
at org.apache.axis.encoding.DeserializationContextImpl.endElement(DeserializationContextImpl.java:1015)
at org.apache.xerces.parsers.AbstractSAXParser.endElement(Unknown Source)
at org.apache.xerces.impl.XMLNSDocumentScannerImpl.scanEndElement(Unknown Source)
at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl$FragmentContentDispatcher.dispatch(Unknown Source)
at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanDocument(Unknown Source)
at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
at org.apache.xerces.parsers.DTDConfiguration.parse(Unknown Source)
at org.apache.xerces.parsers.XMLParser.parse(Unknown Source)
at org.apache.xerces.parsers.AbstractSAXParser.parse(Unknown Source)
at javax.xml.parsers.SAXParser.parse(Unknown Source)
at org.apache.axis.encoding.DeserializationContextImpl.parse(DeserializationContextImpl.java:242)
at org.apache.axis.SOAPPart.getAsSOAPEnvelope(SOAPPart.java:538)
at org.apache.axis.Message.getSOAPEnvelope(Message.java:376)
at org.apache.axis.client.Call.invokeEngine(Call.java:2583)
at org.apache.axis.client.Call.invoke(Call.java:2553)
at org.apache.axis.client.Call.invoke(Call.java:2248)
at org.apache.axis.client.Call.invoke(Call.java:2171)
at org.apache.axis.client.Call.invoke(Call.java:1691)
at com.cognos.developer.schemas.bibus._3.EventManagementServiceStub.trigger EventManagementServiceStub.java:4565)
at Trigger.fireTrigger(Trigger.java:154)
at Trigger.main(Trigger.java:225)

Cause

No "Administration" capability for the user.

Environment

IBM Cognos BI

Resolving The Problem

Add user to have execute and traverse on "Administration" capability.
Steps:

  1. Logon to Cognos Connection as a system administrator.
  2. Go to Tools -> Capabilities.
  3. Click on "Set Properties" for Administration.
  4. In the Permissions tab, add the user to have execute and traverse permissions.
  5. Click OK to save changes.
  6. Test running the trigger. In newer versions of IBM Cognos BI, execute and traverse permission is also required on the "Run activities and schedules" capability, under the Administration capability. Note: Adding the user to Administration capabilities does not mean that user will have access to Directory, Portal Administration, etc. unless you specifically set that user in the sub-functions under Administration.

[{"Product":{"code":"SSEP7J","label":"Cognos Business Intelligence"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Cognos Connection","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.2.2;10.2.1;10.2","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21370772