IBM Support

Portal fixpack upgrade fails with exception WUPD0248E "Failed to perform extraction"

Troubleshooting


Problem

IBM® WebSphere® Portal is successfully installed and configured. The Portal system must be upgraded to the later fixpack. During installation of the fixpack, the installation fails with an exception WUPD0248E and an error message of "failed to perform extraction". This Technote will overview how to diagnose and resolve this error to allow for Portal to be successfully upgraded.

Symptom

In this instance, Portal was being upgraded to v6.1.0.1. However, the same error could occur with an upgrade from Portal v7.0.0.0 to Portal v7.0.0.1 or Portal v7.0.0.2. Reviewing the <timestamp>_WP_PTF_6101_selective-install.log file indicates the following:

    Jar File: / tmp/ptfs/WP_PTF_6101/components/wp.ptf.config/update.jar
    Log File: /opt/ibm/websphere/portalserver/version/log/20090116_054503_WP_PTF_6101_wp.ptf.config_install.log
    Target Dir: /opt/ibm/websphere/portalserver
    Backup Jar: /opt/ibm/websphere/portalserver/version/backup/20090116_054503_WP_PTF_6101_wp.ptf.config_undo.jar
    Tmp Dir : /tmp
    Log Level : 3

    Completed processing extractor command line arguments.
    Performing extraction.

    Failed to perform extraction.
    Exception: WUPD0248E: Fix pack update failure: The processing of fix pack WP_PTF_6101, component wp.ptf.config failed.

Cause

The fixpack installation was performed utilizing a non-root user. Reviewing permissions on the directory structures for the /tmp file indicated the non-root user did not have write permissions on that directory. Therefore, the extraction of the updated .jar files to the /tmp directory failed.

Environment

Any supported UNIX® or Linux™ operating system may be affected.

NOTE: Microsoft Windows operating systems should not be affected by this error message as the user ID used for Portal on Windows must be a member of the local Administrators Group per the Portal 6.1 Information Center.

Diagnosing The Problem


AIX® operating system:

    1. Review the requirements for user and groups permissions for non-root users in the Portal 6.1 Information Center.

    2. Run the following commands:
      "ls -la /usr/IBM"
      "ls -la /tmp"
      "ls -la /var/tmp"

    3. Review the output of the current directory (denoted by a .") in the output. Verify the non-root user and non-root group have correct permissions per the Portal 6.1 Information Center..

Sun® Solaris™, HP-UX®, or Linux operating systems:
    2. Run the following commands:
      "ls -la /opt/IBM"
      "ls -la /tmp"
      "ls -la /var/tmp"

    3. Review the output of the current directory (denoted by a .") in the output. Verify the non-root user and non-root group have correct permissions per the Portal 6.1 Information Center..

Resolving The Problem

Modifying directory permissions:
For this specific error message, the /tmp directory did not have correct permissions as noted in the Portal 6.1 Information Center. Thus, when the Portal Update Installer (PUI) attempted to extract files to this directory, the permissions of the directory did not allow the PUI to write to the directory. Therefore, the fixpack upgrade attempt failed.

To resolve this issue, perform the following commands as the non-root user. We'll utilize the username "fred" belonging to the groupname "fredsgroup" in the following example:

1. Log in as a root user on the machine.
2. Run the following command: chmod -R g+wr /tmp
3. Run the following command: chgrp -R fredsgroup /tmp
4. Verify permissions on the directory by attempting to create a file to the /tmp directory, such as touch /tmp/fredtest.txt
5. Rerun the Portal Update Installer and reattempt the fixpack install.

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Document Information

Modified date:
03 December 2021

UID

swg21367126