IBM Support

Error 'Content Manager failed to start because it could not load driver com.ibm.db2.jcc.DB"Drive' when upgrading to 8.4

Troubleshooting


Problem

I.T. administrator is upgrading to Controller 8.4, from a previous version of Controller. During the upgrade, administrator launches 'Cognos Connection'. Administrator starts the Cognos 8 service, but receives an error message. In addition, the database connection settings have been lost inside 'Controller Configuration'.

Symptom

Administrator opens 'Cognos Configuration', and clicks the green 'start' ('play') button, but receives the following error message:

    IBM Cognos Configuration
    IBM Cognos Configuration is performing the following tasks:
    ! Testing Content Manager database connection.
    Testing the archive location
    ! Testing the mail server connection.
    Checking test results
    Checking upgrade status
    Registering the service 'IBM Cognos 8'
    X Starting the service 'IBM Cognos 8'
    -------------------------------------
    [ ERROR ] The database connection failed.
    [ ERROR ] Content Manager failed to start because it could not load driver 'com.ibm.db2.jcc.DB2Driver'.
    Since the value is empty, the feature is disabled. There is nothing to test.
    [ ERROR ] The mail server cannot be reached
    [ ERROR ] CFG-ERR-0106 IBM Cognos Configuration did not receive a response from the IBM Cognos 8 service in the time allotted.
    Check that IBM Cognos 8 service is available is available and properly configured.
    -------------------------------------

Cause

There are several possible causes for the "could not load driver 'com.ibm.db2.jcc.DB2Driver'" message.

  • For more examples, see separate IBM Technote #1625931.

This Technote specifically relates to the scenario where (during an upgrade to Controller 8.4), the administrator has either:
(1) Installed Controller to a new/different folder (for example D:\Program Files\... instead of C:\Program Files...)
or (2) Mistakenly *renamed* the original installation folder (for example, renamed 'C:\Program Files\Cognos\C8' to 'C:\Program Files\Cognos\C8.backup_before_8.3_upgrade') between the uninstall and re-install process.
  • By renaming the folder, the new Controller version was not installed in a location where there were configuration files from the previous version. In other words, 'Cognos Configuration' and 'Controller Configuration' have lost the files (from the previous installation) which told it what its configuration settings were.
  • Instead, a good practice is to make a backup *copy* of this folder (e.g. copy the folder 'C:\Program Files\Cognos\C8' to 'C:\Program Files\Cognos\C8.backup_before_8.3_upgrade'), so you have a backup in case the upgrade fails.

Resolving The Problem

The best solution will vary depending on circumstances. In one real-life example, the best solution was to:

  1. Uninstall Controller 8.4
  2. Ensure that there is a copy of the old (before the upgrade) C8 folder in the correct place (for example C:\Program Files\Cognos\c8)
  3. Install Controller 8.4 to correct location (for example C:\Program Files\Cognos\c8)

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.4","Edition":"Not Applicable","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21366905