IBM Support

TM1 Perspectives/Windows 2003 Terminal Services - PasteFace Error (282799)

Troubleshooting


Problem

If attempting to run TM1 Perspectives over a Windows 2003 Terminal Server users may receive the following error: Run-time error Method 'PasteFace' of object'_CommandBarButton' failed. User receives the following error in Excel: "Cannot empty clipboard" Users may also receive the "Cannot empty clipboard" error after successfully starting TM1 Perspectives, and attempting to do a "Slice to Excel".

Symptom

Excel error: "Cannot empty clipboard"

Cause

Possible causes:
a) Microsoft bug for which a hotfix is available.
b) Clipboard may be full and must be cleared.

Resolving The Problem

This issue may be due to a known Microsoft bug related to a conflict with the Windows clipboard and the Microsoft Office PasteFace method.

If you are experiencing this problem while running TM1 Perspectives and Windows Server 2003 Terminal Services, see the following Microsoft Knowledge Base article:
http://support.microsoft.com/default.aspx?scid=kb;en-us;840872
"You may not be able to paste an item in an Office 2003 program after you connect to a Windows Server 2003-based server that is running Terminal Server"
which contains a hotfix.

If you are getting this error in Excel while connected through Terminal Server, another option which could resolve this error would be to go to your Terminal Server Configuration and turn off Clipboard Mapping.


Additional possible workarounds (which will help clear/flush the clipboard) and may resolve the error:
1) If you can successfully start Perspectives and are instead encountering this error while attempting to Slice to Excel, the following workaround may resolve the error and allow you to create a slice:
a) Open Notepad.
b) Type a few characters, then select the characters you just typed in.
c) Choose Edit > Copy. This purges the old contents of the Clipboard and replaces them with just a few characters.
d) Create your slice in TM1.

2) Go to Start -> Run -> then type: rdpclip.exe
Click "OK"
Then, go to task manager and look for rdpclip.exe in the processes tab, select rdpclip.exe, and click the "End Process" button.
Close Task Manager and try performing task again (e.g. start Perspectives, etc).

3) Reboot your computer and restart TM1 Perspectives.

4) The following will perform a forced "Clear Complete Clipboard":

Select and copy below code (Ctrl + C)

Option Explicit
Public Declare Function OpenClipboard Lib "user32" (ByVal hwnd As Long) As Long
Public Declare Function EmptyClipboard Lib "user32" () As Long
Public Declare Function CloseClipboard Lib "user32" () As Long

Public Function ClearClipboard()
OpenClipboard (0&)
EmptyClipboard
CloseClipboard
End Function

Sub ccc()
Call ClearClipboard
End Sub

* In Excel open the Visual Basic Editor (VBE) with Alt + F11
* Select any file on left, choose Insert-Module from the menu
* Paste code in right pane Ctrl + V
* Close the VBE with Alt + Q
* Test the code: In Excel run macro 'ccc' by pressing Alt+F8

NOTE: Be aware of the fact, that neither the VB macro ccc nor its use is in any way supported by IBM.

Also see other technotes that mention this error.

[{"Product":{"code":"SS9RXT","label":"Cognos TM1"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"TM1","Platform":[{"code":"PF033","label":"Windows"}],"Version":"9.5.1;9.5;9.4 MR1;9.4","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}},{"Product":{"code":"SS9RXT","label":"Cognos TM1"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"TM1","Platform":[{"code":"PF033","label":"Windows"}],"Version":"9.1;9.0;8.4.5","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Historical Number

1042112

Document Information

Modified date:
15 June 2018

UID

swg21362037