After upgrading to WebSphere Portal 6.1.0.1 themes may not display correct while using Internet Explorer 7

Technote (troubleshooting)


Problem

The end user will see a blank page and the following exception will be in the logs:

DispatcherSer E com.ibm.wps.services.dispatcher.DispatcherServiceImpl handleRequest EJPFD0004E: The dispatcher call resulted in an error.

    java.lang.StringIndexOutOfBoundsException
    at java.lang.String.substring(String.java:1088)
    at com.ibm._jsp._Default._jspService(_Default.java:1229)
    at com.ibm.ws.jsp.runtime.HttpJspBase.service(HttpJspBase.java:87)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:856)

Cause

There were some changes made to the IBM-provided Dojo directory. If the custom theme is still using the IBM-provided Dojo instead of including its own version, this problem may occur.

Resolving the problem

In the head_extras.jspf file for the failing theme, do the following:


Change

    contentHandlerRoot = pocUrl.substring(0, endIndex);
to
    contentHandlerRoot = pocUrl.substring(0, endIndex > 0 ? endIndex :
    pocUrl.length());

    Save head_extras.jspf
    Touch and then save head.jspf
    Touch and then save Default.jsp

If reloading a .jsp is not enabled on the server, a restart may be needed.


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Document information


More support for:

WebSphere Portal
Application Development

Software version:

6.1.0.1

Operating system(s):

AIX, Linux, Solaris, Windows

Software edition:

Enable

Reference #:

1358731

Modified date:

2012-12-05

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