Users with Author access cannot reserve rooms or resources

Technote (troubleshooting)


Problem

In Lotus Notes, if you have author access in the access control list (ACL) and attempt to book a room or resource in the Resource & Reservations (R&R) database, the New Reservation and Quick Reservation buttons do not display. This prevents booking any room or resource.

This situation occurred after an upgrade from Notes 8.0.1 to 8.0.2.



Cause

The 8.0.2 release contains a fix that prevents users without write access ("Write public documents" in the ACL) to see the New Reservation and Quick Reservation buttons.

Resolving the problem

To resolve the problem, it is now required that users have the "Write public documents" right enabled in the ACL to create new and quick reservations directly in the resource database.

(File --> Database --> Access Control --> Basics panel --> "Write public documents").

Without the "Write public documents" right enabled, users may still book reservations from their calendar with no problem.

"Hide When" code that results in this problem was introduced to fix another issue reported in the 8.0.1 release as SPR# BKAN7E2MRB. If you look at the Hide When code in Lotus Domino Designer (!(tmpLevel >=3 & tmpWrite="1")), you can see the tmpWrite="1" value which indicates that writing public documents must now be manually enabled.


Related information

A simplified Chinese translation is available


Rate this page:

(0 users)Average rating

Document information


More support for:

IBM Notes
Calendaring and Scheduling

Software version:

8.0.2

Operating system(s):

Linux, Mac OS X, Windows

Software edition:

All Editions

Reference #:

1358613

Modified date:

2013-05-06

Translate my page

Machine Translation

Content navigation