Troubleshooting
Problem
A problem occurs when launching TM1 Perspectives (tm1p.xla). If the user on the client-machine is not administrator of the local pc, he receives a Run-time error.
Symptom
Microsoft Visual Basic
Run-time error '429':
ActiveX component can't create object
C:\Program Files\IBM\cognos\tm1\bin\tm1p.xla
Windows cannot find 'C:\Program Files\IBM\cognos\bin\tm1p.xla'. Make sure you typed the name correctly, and then try again. To search for a file, click the Start button, and then click Search.
Cause
The Tm1prc.dll is not correctly registered during installation and users with restricted operating system rights cannot register *.dll files.
Resolving The Problem
The three active-x components tm1prc.dll, tm1xl.ocx and tm1dasrv.dll have to be reregistered by a local Administrator.
Steps:
1) Login as local Administrator on the client machine
2) Reregister the three mentioned active-x components, (tm1prc.dll, tm1xl.ocx and tm1dasrv.dll) by going to a command prompt and cd to the TM1 installation directory bin folder and issue the following command:
Regsvr32.exe -u tm1prc.dll tm1xl.ocx tm1dasrv.dll
A message should appear that this succeeded.
NOTE: If registering on a Windows 2008 server or Windows 7, also right-click on the Command Prompt and choose Run as Administrator, even though the user is an administrator.
Then run:
Regsvr32.exe tm1prc.dll tm1xl.ocx tm1dasrv.dll
3) Launch Perspectives while still logged in as Administrator
4) Log off as Administrator
5) Login as non-admin user
NOTE: if this does not work then it may require that the actual Administrator user is used, rather than just a user who is a local admin. In this case, log in as Administrator, and then perform steps 2 to 5.
Related Information
Historical Number
1040794
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Document Information
Modified date:
15 June 2018
UID
swg21351371