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Impromptu report against DB2 on AS400: Extended dynamic support is disabled.

Troubleshooting


Problem

Attempts to run an Impromptu report against a DB2 database on AS400 fails with an error

Symptom

[IBM][iSeries Access ODBC Driver][ Extended dynamic support disabled

DMS-E-GENERAL, A general exception has occurred durion operation, 'Prepare Request'.

[IBM][iSeries Access ODBC Driver][DB2 UDB]SQL5001 - Column qualifier or table T1 undefined

Cause

ODBC definition configured using Server settings for naming convention set to "System naming convention (*SYS)". This caused the server to library delimiter character to use a "/' rather than standard ".".

Environment

iSeries access for windows V5R3M1

Resolving The Problem

1) Invoke Microsoft ODBC datasource administrator accessed via: Administration Tools-> Data Sources (ODBC)

2) Select the ODBC connection definition and select the configuration button.

3) Select the Server tab.

4) Changed to "SQL naming conventions (*SQL) and restarted Impromptu and the "/" qualification changed to a "." and the report ran.

[{"Product":{"code":"SSTQPQ","label":"IBM Cognos Series 7 PowerPlay"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Impromptu","Platform":[{"code":"PF033","label":"Windows"}],"Version":"Impromptu 7.4","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Historical Number

1038032

Document Information

Modified date:
15 June 2018

UID

swg21351208