Troubleshooting
Problem
User launches Controller client. User is asked for their username/password. Crucially (however) they are not asked to choose a database. Why not?
Symptom
During the logon process, the "Select Database" screen is not seen:
Cause
End user has disabled the setting to allow the use of multiple databases.
- In other words, the setting "Database Selection Mode" is unticked:
More Information:
The ability to see multiple databases is configured by the end user (not by a central administrator). The setting is on a per-user basis.
Resolving The Problem
Ask the end user to enable the database selection function.
Steps:
- Method #1 (easiest - recommended)
1. Launch Controller
2. Click 'Maintain - Database - Database Selection Mode'
- This should mean that it is now ticked:
3. Retry.
- Method #2
1. Click "START - RUN"
2. Type the following: notepad %appdata%\cognos\ccr\ccr.config
3. Inside notepad, search for the entry "SelectDb"
4. Modify its value to be "True" (see below):
5. Save changes and test.
[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.2.0;10.2.1;10.3","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]
Historical Number
1039399
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Document Information
Modified date:
15 June 2018
UID
swg21347818