Technote (troubleshooting)
Problem(Abstract)
User launches Consolidator. User receives error message.
If user ignores the message (and carries on using Consolidator) user may receive different errors when trying to use other functionality (e.g. perform a database optimisation).
Symptom
Initial error (when launching Consolidator)
Microsoft Visual FoxPro
The resource file is not valid. Overwrite it with a new empty one?
Yes / no
Other potential errors (if user continues to use Consolidator):
(1) Performing a database optimisation:
-
<Rebuilding database container
FRANGO.DBC>
Program Error
File access is denied.
[Cancel] [Ignore] [Help]
(2) Running an Excel link report:
-
Open Table
Table 'xbolvkd.dbf' is not marked as belonging to the 'frango' database. Would you like to create the back link to mark it?
[Yes] [No]
If click "yes" then get the following error:
-
Program Error
File must be opened exclusively.
[Cancel] [Ignore] [Help]
Cause
NTFS file permissions do not allow earlier versions of Visual FoxPro resource files to be upgraded to later versions.
These 2 files are:
- foxuser.dbf
- foxuser.fpt
Environment
Typically occurs when Consolidator is upgraded to new version, especially on a locked-down environment (e.g. Citrix server) where the end user is not a member of the local Windows group "Administrators".
Resolving the problem
Workaround:
Simply click on either 'yes' or 'no' (it does not matter) and carry on.
- NOTE: Depending on the environment, you *may* experience different errors later when using Consolidator.
Fix:
Modify the NTFS permissions on the files foxuser.dbf and foxuser.fpt, to give read/write access to group 'everyone':
Steps
- Logon to the client PC (or Citrix server) as a Windows administrator
- Open the folder C:\WINDOWS\SYSTEM32
- Right-click on the file foxuser.dbf and choose 'properties'
- Click on tab 'security'
- Click 'Add'
- Enter the group 'Everyone' and click OK
- Highlight 'Everyone' and tick the box 'Full Control' under column 'Allow'
- Click OK
- Repeat steps 3-8, but this time for file foxuser.fpt
- Open the installation folder (e.g. C:\FRANGOW)
- Repeat steps 3-9
- Restart Consolidator
- When the message again appears, confirm the question with 'YES'
Historical Number
1038939
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