IBM Support

Cognos BI Windows service ("Cognos 8" / "IBM Cognos 8" / "IBM Cognos") does not start automatically after a reboot

Troubleshooting


Problem

I.T. administrator reboots Controller application server, during a period of downtime. After the reboot has finished, Controller users cannot logon. Instead, they receive an error message. After some troubleshooting, it is found that the cause is that the Cognos BI service (by default also located on the Controller application server) has not successfully started. However, if it is manually started then it works OK. Why does the Cognos BI service not start automatically after a server reboot?

Symptom

The error message seen (when trying to launch Controller) varies depending on which version of Controller you are using. Below are some examples:

Controller 8.3.x and earlier:

    Log On Controller
    Cognos Business Intelligence
    The Cognos Gateway is unable to connect to the Cognos BI server. The server may be unavailable, or the gateway may not be correctly configured.
    Please try again or contact your administrator.
Controller 8.4 and some later versions:
    IBM Cognos 8 Business Intelligence
    The IBM Cognos gateway is unable to connect to the IBM Cognos BI server. The server may be unavailable or the gateway may not be correctly configured.
    Try again or contact your administrator.

Controller 10.1.1:
    IBM Cognos Business Intelligence
    The IBM Cognos gateway is unable to connect to the IBM cognos BI server. The server may be unavailable or the gateway may not be correctly configured.
    Try again or contact you administrator.

Cause

The Controller application server runs a Windows service which runs the Cognos 8 BI reporting engine. The name of the service will vary depending on the version of Controller that was originally installed on that server. Below are the default names of the Windows service for each version of Controller:

  • 8.1/8.2/8.3 - Cognos 8
  • 8.4/8.5 - IBM Cognos 8
  • 10.1 - IBM Cognos

See below for an example based on Controller 10.1.1:


This Windows service has its 'startup type' set to 'automatic', which means that in theory (after a reboot) the service will try to automatically start.

This Technote only relates to the scenario where:
  • (after a reboot) this Windows service is failing to start automatically
  • However, if the I.T. administrator manually clicks the button "Start" then it works OK.

The cause of the failure (to start automatically immediately after a reboot without manual intervention) is third-party (for example Microsoft) software or settings which disallow the "IBM Cognos" service from starting (correctly) until other parts of the server are 'ready'.

Again there are many potential causes for this.
  • One of the most likely causes is that the database server (for example the SQL or Oracle server) has not yet started running successfully. This will mean that the "ContentStore" database (where the IBM Cognos Windows service stores its settings) is not yet available. This will cause the service to fail to start.

Environment

This problem is rare. In almost all environments, the Cognos BI service will start correctly automatically.

It is most likely to occur in environments where there is a lot of non-Controller software installed on the Controller application server.

Diagnosing The Problem

This Technote only relates to the scenario where the IBM Cognos (BI) service starts OK when the I.T. administrator manually starts it (by clicking 'Start').

  • There are many potential causes for the IBM Cognos (BI) service never starts correctly (even if started manually)
  • See separate IBM Technotes for some explanations for this.

Resolving The Problem

Fix:
There are several methods that will solve the problem. Depending on your customer environment, choose one of the following:

Method #1
Create a 'scheduled task' to run after the server boots up. This task will:

  • Wait 3 minutes (to give the time for other systems to start up)
  • Then start the service.

Steps:
NOTE:
  • The following instructions are based on Windows 2003. You will need to modify the instructions slightly for Windows 2008
  • They also assume that the Windows service name is "cognos 8". You will need to modify the instructions slightly for a different name.

1. Logon to the Controller application server as a Windows administrator
2. Launch Notepad and create a file called:
C:\Program Files\cognos\DO_NOT_MOVE_OR_DELETE_Cognos_8_Windows_service_start.bat
3. Populate this file with the following text:
      REM following written by Richard.Collins@Cognos.com
      REM to wait 3 minutes and then start the 'Cognos 8' service
      REM this is called from a Scheduled Task after server boots
      sleep 180
      net start "cognos 8"

4. Locate a copy of Microsoft's sleep.exe.
TIP: You can download the Windows 2000 Server Resource Kit, and install it onto a spare PC, to get this file.

5. Copy the file "sleep.exe" into the folder C:\WINDOWS
6. Click 'Start - Settings - Control Panel'
7. Launch Scheduled Tasks
8. Double-click on 'Add Scheduled Task'
9. Navigate through the 'Scheduled Task Wizard' as appropriate
10. Browse and select the task to run as C:\Program Files\cognos\DO_NOT_MOVE_OR_DELETE_Cognos_8_Windows_service_start.bat
11. Name the task appropriately, such as 'DO_NOT_MOVE_OR_DELETE_Cognos_8_Windows_service_start'
12. When asked, choose task to run 'When my computer starts'

Finally, during a period of downtime, reboot the server and test that the Cognos 8 service has started correctly

~~~~~~~~~~~~~~~~~~~~~~~~~~
TIP: If you are using an all-in-one SQL/APP server (where SQL is installed on the same Application server - for example as a demonstration/test server), then you may find you need to also delay the SQL server from starting for a few minutes.
  • For example if SQL needs access to an external hard drive which is not instantly available

In this scenario, assuming that the Windows service is called "IBM Cognos 8", perform the following:
  • Set the following Windows services to manual: "SQL Server (MSSQLSERVER)", "IBM Cognos 8"
  • Modify the batch job to have the following contents:
      REM to wait 3 minutes then start SQL service then wait 2 mins and start 'Cognos 8' service
      REM this is called from a Scheduled Task after server boots
      SLEEP 180
      net start "SQL Server (MSSQLSERVER)"
      SLEEP 120
      net start "IBM Cognos 8"
~~~~~~~~~~~~~~~~~~~~~~~~~~

Method #2
It is possible to make the relevant Windows service (for example "IBM Cognos") 'dependant' on another Windows service:

This will delay the startup of the "IBM Cognos" service, until a time when it can successfully start.
  • To do this, follow the recommendations inside Microsoft KB article 193888.

Workaround:
After each reboot, either:
(1) Launch "Cognos Configuration" (from the Start Menu) and click the 'Start' icon (near the top-left corner):


or (2) Start the relevant Windows service manually from inside the Windows services GUI.

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Historical Number

1035901

Document Information

Modified date:
28 November 2022

UID

swg21347377