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** Troubleshooting ** blank screen / white screen when launching Controller client from Cognos Connection website

Troubleshooting


Problem

User launches the Cognos Connection website inside Internet Explorer (for example http://servername/ibmcognos). User clicks "Consolidate my Financial Information" (in older Controller versions, this icon is simply labeled 'Cognos Controller'. A blank screen (white screen) appears, but the Controller client does not appear to start launching on the screen.

Symptom

Depending on the environment (and how you chose to launch Controller), the end user will see slightly different symptoms. For example, you may find that one the following descriptions fits the problem best:

Cause

There are several possible causes for these symptoms:

  • Scenario #1 - Client device has Internet Explorer 8 (or later) installed
    • By default, IE8's trusted sites zone's security settings are too restrictive
    • See separate IBM Technote 1385244 for more information
  • Scenario #2 - The client PC's Microsoft Internet Explorer has not been configured to trust the Controller website, so will not allow the download of the Controller client software code
    • See separate IBM Technote 1346813 for more information
  • Scenario #3 - The client PC's Microsoft .NET Framework client has not been configured to trust the Controller website, so will not allow the running of the Controller client software code.
    • See separate IBM Technote 1346813 for more information
  • Scenario #4 - Customer using 64-bit client device with unsupported Controller client version
    • See separate IBM Technote 1398186 for more information
  • Scenario #5 - 64-bit client device not configured correctly for running 32-bit code
    • See separate IBM Technote 1398266 for more information
  • Scenario #6 - Misconfiguration on the IIS website
    • For example, the value of 'Enable content expiration' was set to 'enabled' and set to 'expire immediately'.
    • See separate IBM Technote 1416815 for more information
  • Scenario #7 - Problem downloading and installing the Excel link client to the client device.
    • This IBM Technote mainly relates to this scenario.
  • Scenario #8 - Microsoft bug when using Windows 8.1
    • Specifically, Microsoft IEEXEC cannot read the ccr.config file correctly.
    • See separate IBM Technote 1685173 for more information

More Information on Scenario #7:
By default, the Controller website checks to see whether the end-user has the Controller Excel link client installed. If the client PC does not have the Excel link installed, then the website attempts to automatically 'push' the software to the client PC. However, if any settings on the user's PC prevent the automatic download of software, then this will fail (without an error message) and Controller will abort its launch process.

The settings that must be correct include:
  1. .NET client software and trusts must be correct
  2. Internet Explorer zone settings must allow software installations
  3. Microsoft Excel itself must be installed on the PC.

Resolving The Problem

Scenario #1
Modify client device's Internet Explorer 8 zone security.

  • See separate IBM Technote 1385244.

Scenario #2
Configure the client PC's Microsoft Internet Explorer to trust the Controller website.
  • See separate IBM Technote 1346813.

Scenario #3
Configure the client PC's Microsoft .NET Framework client to trust the Controller website.
  • See separate IBM Technote 1346813.

Scenario #4
Upgrade to later version of Controller which supports 64-bit client devices.
  • See separate IBM Technote 1398186.

Scenario #5
Reconfigure 64-bit client device to allow running of 32-bit code.
  • See separate IBM Technote 1398266.

Scenario #6
Reconfigure IIS.
  • See separate IBM Technote 1416815.

Scenario #7:

Either:

  1. Modify the client PC settings so that it allows the automatic download (and installation) of the Controller Excel link client software
  2. Or (alternatively) manually install the Excel link MSI on the affected client PC.


    Steps:

    * Solution #1:

    1. Launch Internet Explorer
    2. Click "Tools" - "Internet Options" - "Security"
    3. Click "Trusted sites" - "Sites"
    4. Add the server (
       http://<servername> 
      ) to the list
    5. Afterwards, click "custom level" and ensure that the "reset custom settings" section is set to "medium-low" (or "low"), and then click the "reset" button.

    * Solution #2:
    The exact nature of the steps varies depending on Internet Explorer version, Security Zone configuration and I.T. security policy of the environment. However, typically you would do the following:
    1. Ensure that you are logged onto the PC as an administrator
    2. Enter the following URL inside Internet Explorer:
       http://<servername>/cognos8/controllerbin/ControllerClient.MSI 
    3. When prompted, choose to "save" the file (e.g. onto the desktop)
    4. Manually install the software by double-clicking on the file ControllerClient.MSI

Workaround:

Modify the settings of the Controller website so that it does not automatically attempt to install the Excel link on client PCs.

TIP: If you are trying to launch Controller on a PC/server which does not have Microsoft Excel installed, then this is the only possible workaround.


    Steps:
    1. Logon to the Controller application server (webserver) as an administrator
    2. Launch Controller Configuration from the start menu
    3. Open the section 'Client Distribution Server' - 'Client Distribution Server Config'
    4. Change the setting for 'InstallExcelLink' from "true" to "false".

Scenario #8
Apply a Microsoft software fix to Windows 8.1.
  • See separate IBM Technote 1685173.

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.2.0;10.1.1;10.1;8.5.1;8.5;8.4;8.3","Edition":"Not Applicable","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Historical Number

1032892

Document Information

Modified date:
15 June 2018

UID

swg21347103