IBM Support

Getting error (CNC-BAL-0509) and (CNC-DS-0001) while running scheduled reports

Troubleshooting


Problem

When trying to run scheduled report which send output by email, we encountered the below error message. If we check the status of the report in Cognos administration, its status is unavailable in the "run by" column.

Symptom

CNC-BAL-0509 One or more errors have occurred. Your request could not be fully processed.

In the file cogserver.log under the logs folder where Cognos 8 is installed. The below error message was logged

<trace>CNC-DS-0001 The following Delivery Service general error occurred: Could not connect to SMTP host: mailserver, port: 25Could not connect to SMTP host: mailserver, port: 25</trace>

Problem with mail server, will test again in 10 seconds

Cause

Delivery service was disabled.

Environment

Windows, Unix

Resolving The Problem

1) Enable Delivery service.

A. Delivery service can be enable in IBM Cognos Administration - under status section.

or

B. Cognos configuration (require a restart of Cognos 8) - under Environment, Cognos 8.

2) Check if SMTP server is up and running. It is required to be up and running in order to forward report or report link to the intended recipients.

[{"Product":{"code":"SSEP7J","label":"Cognos Business Intelligence"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Report Studio","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"10.2;10.2.1;10.2.1.1;10.2.2","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Historical Number

1041818

Document Information

Modified date:
15 June 2018

UID

swg21343405