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CM-SYS-5007 when trying to start Cognos 8 service in cogserver.log

Troubleshooting


Problem

Cognos 8 service does not start and the cogserver.log contains the error message below.

Symptom

Warning CM-SYS-5007

tried to access class oracle.jdbc.driver.OracleResultSet from class com.cognos.cm.dbstore.CMDbStoreOracleLOBSupport

Runtime Exception stack trace:
java.lang.IllegalAccessError: tried to access class oracle.jdbc.driver.OracleResultSet from class com.cognos.cm.dbstore.CMDbStoreOracleLOBSupport
at com.cognos.cm.dbstore.CMDbStoreOracleLOBSupport.getBLOBStream(CMDbStoreOracleLOB Support.java:33)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.jav a:25)
at java.lang.reflect.Method.invoke(Method.java:585)
[...]

Cause

Corruption of the JDBC-driver.

Environment

System Z, Oracle 10g

Resolving The Problem

Replace the JDBC-driver in Cognos with the one from the DB-client.

Steps:
  1. Navigate to your Oracle DB-Client <OracleClient_ROOT>/jdbc
  2. Copy the JDBC-driver (ojdbc14.jar or classes12.zip - depends on your Cognos 8 / JRE version) to the following directory:

<C8_ROOT>/webapps/p2pd/WEB-INF/lib

[{"Product":{"code":"SSEP7J","label":"Cognos Business Intelligence"},"Business Unit":{"code":"BU053","label":"Cloud \u0026 Data Platform"},"Component":"Install and Config","Platform":[{"code":"PF016","label":"Linux"}],"Version":"8.3","Edition":"","Line of Business":{"code":"","label":""}}]

Historical Number

1041050

Document Information

Modified date:
28 November 2022

UID

swg21343265