Troubleshooting
Problem
A user logging into Cognos and launching one of the Studios get the following error message when trying to launch any Studio in Cognos Connection.
Symptom
CM-SYS-5006
Content Manager is unable to process your request because an unexpected event occurred in the
content store database subsystem.
Details
CM-SYS-5027 A Content Manager internal error occurred while querying the content store cache.
CacheQuery::Parse::/1:*:*[F28(L33:iEBF665F260A0430FA4AE92C38390098D)]Unknown Exception while
parsing steps::Step #=0MultilingualStringsCache.Parse::Invalid function specified in cache expression
Cause
The user profile is corrupted in the content store.
Resolving The Problem
Remove and re-add the user profile from Cognos connection:
Steps:
- Login as System Administrator or Directory Administrator and delete the user profile from Cognos Connection (Launch -> IBM Cognos Administration, select Security and then the authentication source, navigate to the user's name and click More under the actions column, and then select Delete this user's profile)
- Leave the account in-tact in your third-party authentication source.
- Ask the user to login to Cognos Connection with the same credentials, and verify that the account is re-established automatically.
** NOTE: ****
Please read the following first before recreating the user profile:
- Before you delete a user profile, you may want to view the content to ensure that you are not deleting anything important. Please see the View or Change a User Profile reference below for more information.
- Backup the contents of My Folder for this user (you may want to move the objects to "Public Folders" temporarily).
- Perform a backup of the content store as a precaution.
References:
See the following references from the Cognos 8 Administration and Security Guide:
Delete a User Profile
View or Change a User Profile
Steps::Step #=0MultilingualStringsCache.Parse::Invalid function specified in cache expression
Root Cause:
The user profile is corrupted in the content store.
Solution:
Remove and re-add the user profile from Cognos connection:
Steps:
- Login as System Administrator or Directory Administrator and delete the user profile from Cognos Connection (Tools -> Directory, select the authentication source, navigate to the user's name and click More under the actions column, and then select Delete this user's profile)
- Leave the account in-tact in your third-party authentication source.
- Ask the user to login to Cognos Connection with the same credentials, and verify that the account is re-established automatically.
** NOTE: ****
Please read the following first before recreating the user profile:
- Before you delete a user profile, you may want to view the content to ensure that you are not deleting anything important. Please see the View or Change a User Profile reference below for more information.
- Backup the contents of My Folder for this user (you may want to move the objects to "Public Folders" temporarily).
- Perform a backup of the content store as a precaution.
References:
See the following references from the Cognos 8 Administration and Security Guide:
Delete a User Profile
View or Change a User Profile
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Document Information
Modified date:
28 November 2022
UID
swg21341527