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Unable to run reports: RSV-BBP-0022 and RSV-SRV-0042

Troubleshooting


Problem

When a report is run, an error message occurs. If the same report is run again it may run with no error message.

Symptom

In Cognos 10:
RSV-BBP-0022 The absolute affinity request 'asynchWait_Request' failed, the requested session does not exist.
Details: RSV-SRV-0042 Trace back

Cause

This error typically indicates a timing condition in long-running reports. Reports that run for more than 7 seconds enter an "asynchronous communication" mode. In this mode, the session sends periodic "wait()" requests to retrieve the data. If this request isn't received for over 30 seconds (the default async timeout) due to delays in the architecture, the dispatcher closes the session. This error is generated when the dispatcher then receives the "wait" request for the closed session.

Resolving The Problem

Possible environmental causes and solutions of this error:

  1. Ensure that the minimum hardware requirements for Cognos 10 have been met.
  2. Ensure that settings for a local firewall are not interfering with Cognos 10. Either disable the local firewall, or if that is not an option, modify the firewall settings for the Cognos 10 ports.
  3. Ensure that multiple browsers (more than 2) aren't being used on the workstation, as this may interfere with the communications.

[{"Product":{"code":"SSEP7J","label":"Cognos Business Intelligence"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Report Studio","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"10.2;10.2.1;10.2.2","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21340994