Troubleshooting
Problem
Overnight scheduled jobs fail in a multiserver environment.
Symptom
CNC-JOB-0004 An error has been encountered in one of the steps associated to the job
Cause
timing of server reboots
Resolving The Problem
Change the time of night that Cognos servers are restarted so that there are no active schedules. For example, if reports are scheduled to kick off at 5:05 AM, it is unlikely that a multiserver environment (or a slower single server) will be up and ready to process those requests in such a short time frame.
In addition, make sure there is a sufficient amount of time between server reboots so that the distributed components are brought back up properly. This is especially true for the content manager server which must be up and fully running before any of the other servers are restarted. Once the primary content manager is active and running, the application tier servers (report servers) are next, with gateway servers restarted last.
Historical Number
1026531
Was this topic helpful?
Document Information
Modified date:
28 November 2022
UID
swg21340925