Troubleshooting
Problem
When trying to login to IBM Cognos 10, non Cognos System Administrators cannot login. Cognos System Administrators can login successfully.
Symptom
CM-REQ-4158 The search path 'storeID('')' is invalid.
CM-REQ-4078 The function 'storeID' has an invalid argument.
Cause
Lack of Cognos permissions on the namespace in Cognos Connection
Resolving The Problem
Verify the 'everyone' group has the appropriate rights to traverse the directory entry in Cognos connection and verify that the users have appropriate rights to the account.
Steps:
1. Click on Launch > IBM Cognos Administration
2. Click on the Security tab and make sure that Users, Groups and Roles is selected
3. Click on the properties icon for the namespace the users are trying to login to
4. On the permissions tab, be sure the 'everyone' group has READ and TRAVERSE permissions.
5. View the contents of the namespace the users are trying to login to.
6. Browse to the user accounts. Check the permissions. Make sure that
'Override the access permissions acquired from the parent entry' is enabled and that the user has
all permissions (Read, Write, Execute, Set Policy, Traverse) for his own account.
7. Check all permissions for folders above the accounts. For
example, when using a Series 7 Namespace, check the permissions of 'Users' in
the contents of the namespace the users are trying to login to. Make sure that
'Override the access permissions acquired from the parent entry' is enabled and
that there are 'No entries.' in the permissions box.
8. Click on the properties icon for the Cognos namespace
9. On the permissions tab, be sure the 'everyone' group has READ and TRAVERSE permissions.
Was this topic helpful?
Document Information
Modified date:
15 June 2018
UID
swg21340253