IBM Support

Unable to start Cognos Configuration because the configuration data is locked by another instance

Troubleshooting


Problem

Using cogconfig.sh -s, occasionally get an error saying that the configuration has been locked.

Symptom

Unable to start Cognos Configuration because the configuration data is locked by another instance of Cognos Configuration

Cause

Cognos Configuration is either already in use, or was last shutdown with errors.

Environment

UNIX (all platforms)

Resolving The Problem

When Cognos Configuration is started, a cogstartup.lock file is created. If this file is present, the lock is enabled. Delete this file to release the lock.

From the Cognos Configuration User Guide:

"You may get an error message that the configuration data is locked by another instance of Cognos Configuration. When you start Cognos Configuration, it checks to see if the cogstartup.lock file exists in c10_location/configuration. The file may exist if a previous instance did not shut down properly or if another instance of Cognos Configuration is running. If another instance of Cognos Configuration is running, you should exit that instance. Otherwise, any changes you make to the local configuration may result in errors. If no other instance of Cognos Configuration is running, delete the cogstartup.lock file in c10_location/configuration. If the Cognos component service is stopped, click Start."

[{"Product":{"code":"SSEP7J","label":"Cognos Business Intelligence"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Install and Config","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"10.2;10.2.1;10.2.2","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21340141