Question & Answer
Question
When installing the Cognos Software Development Kit (SDK) on a computer without IBM Cognos BI components, an error occurs in the Cognos Installer program.
Cause
The SDK needs to be installed in a location where Cognos components of the same build AND same Bit Size of 32 / 64 Bit already exist.
Answer
From the IBM Cognos SDK Installation and Configuration Guide ig_crn_sdkcd.pdf :
Before you begin
Before you install the IBM Cognos Software Development Kit, ensure that the server components for your IBM Cognos product are installed.
The above statement does advise to have a IBM Cognos BI Server installed.
It is recommended to have this environment for testing of the SDK Application Development, using the simple IBM Cognos Content Store (Derby) instead of any other Major Database installs.
The Cognos Installer will be providing options to do so, and allows a Basic installation of the IBM Cognos Server product for Testing or Demonstration purpose.
Optionally, a SDK Installation can be done within the following Software Components, respecting the Bit Size of these components :
- IBM Cognos Business Intelligence Server 32Bit / 64Bit
- IBM Cognos Framework Manager - 32Bit only.
- IBM Cognos Transformer - 32Bit / 64Bit
- IBM Cognos Dynamic Query Analyzer 32Bit / 64Bit
Refer to your base IBM Cognos Installation directory and the cmplst.txt to determine what software exists in the intended SDK installation already.
Historical Number
1017783
Was this topic helpful?
Document Information
Modified date:
24 February 2020
UID
swg21339335