IBM Support

Error when running userint.exe to uninstall Installation Manager: No Java virtual machine was found

Troubleshooting


Problem

The userinst.ini for IBM Installation Manager contains invalid path for JVM, therefore userinst.exe cannot startup.

Symptom

Attempts to remove IBM Installation Manager as a non-admin user account results in the following error message:

A Java Runtime Environment (JRE) or Java Development Kit (JDK) must be available in order to run Userinst.  No Java virtual machine was fount after search the following location:...

Cause

This is a known defect. The userinst.ini file contains an invalid JRE path. This defect occurs if you have upgraded from v1.2 to v1.2.1.

Resolving The Problem

To resolve the issue, you must edit the userinst.ini file in C:\Documents and Settings\<username>\Application Data\IBM\Installation Manager\uninstall\ by replacing jre_5.0.2.sr5_20070511 with jre_5.0.3.sr8a_20080811b.

Note: Contact IBM Support for further assistance if the workaround does not resolve your issue.

[{"Product":{"code":"SSDV2W","label":"IBM Installation Manager"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Uninstall","Platform":[{"code":"PF033","label":"Windows"}],"Version":"1.2.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
25 October 2021

UID

swg21330900