IBM Support

On AIX, I restart archpro process but it fails to initialize.

Troubleshooting


Problem

I have restarted IBM CommonStore for Lotus Domino Version 8.3 archpro server on AIX after updating archint.ini but it fails to initialize and terminates immediately. Similar problem can occur for IBM CommonStore for SAP.

Symptom

When the archpro server is started, the web dispatchers, domino dispatchers, and other agents will fail to be initialized. You will see error like the following from the console:

CSS9019E: Initialization of Notes/Domino Dispatcher failed. Reason: <A remote host refused an attempted connect operation.>. Exiting...

You can also find similar errors in the startup trace and archint.trace.

Cause

There might be some changes that introduces IPv6 in the network.

During start up of the archpro server, archpro (a C component) opens a port and listens on this port. The child processes such as the CM agents and Web Dispatchers (a Java component) will be started by archpro and they will connect to the port that archrpo server listens on.

CommonStore Version 8.3 supports only IPv4. While the C component is not affected even after IPv6 is introduced in the network, the Java component is IPv6-aware and cannot function in such environment.

Environment

CommonStore version 8.3 is not IPv6 ready.
CommonStore version 8.4 or above is IPv6 ready.

Diagnosing The Problem

  • Verify that C components work:
    • Remove all the dispatchers and agents in the server configuration profile, i.e. archint.ini,
      ADSMAGENTS 0
      CMAGENTS 0
      VIAGENTS 0
      ODAGENTS 0
      DOMINODPS 0
      WEBDPS 0
    • Save the file and restart archpro server. Archpro will be successfully started.

    • While archpro is still running, you issue the command archadmin from another command window.

      For example:
      > archadmin
      CSS3760I: ArchAdmin 8.3.0.0 opens connection to CommonStore server
      CSS3750I: Fixed port will be extracted from ini file 'archint.ini'.
      CSS3755I: Connection to ArchPro on machine 'localhost' on internal UNICODE port 2184 established. Receiving messages from ArchPro...

      If you see that ArchAdmin successfully connects to the CommonStore server, it implies that the C components are working.

  • Test with the Java components:
    • Increase WEBDPS to 1 in archint.ini.
    • Save the file and restart archpro server.
    • If archpro fails to initialize, there is a problem with the Java component and the problem could be related IPv6 being introduced to the network.

Resolving The Problem

  • Add an environment variable on AIX such that it will bind to IPv4 address.
  • export NSORDER=bind4,local

  • You can enter the above in a console or add it to the user profile.

[{"Product":{"code":"SS6QFT","label":"CommonStore for Lotus Domino"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Server","Platform":[{"code":"PF002","label":"AIX"}],"Version":"8.3","Edition":"All Editions","Line of Business":{"code":"LOB45","label":"Automation"}},{"Product":{"code":"SS6QJP","label":"CommonStore for SAP"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Server","Platform":[{"code":"PF002","label":"AIX"}],"Version":"8.3","Edition":"All Editions","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21330816