IBM Support

Installation Manager fails to remove files after an uninstallation

Question & Answer


Question

What should you do if IBM Installation Manager reports that the uninstallation did not delete files or registry keys?

Cause

Installation Manager cannot delete files when the files are in use. Registry keys are not deleted if the registry keys do not exist or if the current user does not have permission to modify the parent hive.

Answer

WORKAROUND:

To circumvent this issue, you must remove the files and registry keys.

  1. Restart the computer.
     
  2. Move the files that were not deleted to a temporary location.

    If you try to install in the same directory without removing the files, the installation will fail. If all Rational products have been uninstalled, the <installdir> and <program files>/Common Files/Rational folders might be deleted.
     
  3. For registry keys that were not deleted, check whether the registry keys exist.
     
    Disclaimer

    This solution contains information about modifying the system registry. Before making any modifications to the Microsoft Registry Editor, it is strongly recommended that you make a backup of the existing registry. For more information describing how to back up the registry, refer to Microsoft Knowledge Base article 256986

    1. If the registry keys do exist, delete them.

      For more information about which keys to delete, you can revise the Technote How to manually uninstall ClearCase on Windows
       
    2. If all Rational products have been uninstalled, the HKEY_LOCAL_MACHINE\Software\Rational Software hive can be deleted, including all of it's sub-keys. On 64-bit hosts also check for and delete the registry keys: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Software\Rational Software\ and all of it's sub-keys.

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Document Information

Modified date:
10 August 2018

UID

swg21328226