IBM Support

Error: 'error 1603' rolling out SMS Notes 8 upgrade with transform file

Technote (troubleshooting)


Problem

When you attempt to upgrade from Lotus Notes 7 to Notes 8.0.2 through Microsoft SMS Distribution using a silent install with a transform file, you receive the following error:


      "error 1603".

Notes 7 is uninstalled but the error occurs while upgrading to Notes 8.0.2 and leaves the workstation without a functioning Notes client. The install works correctly if run from a command line.


Cause

Special Characters in the install directory " ; | * ? < > ! # & $ ` , ' = ^ @". Eclipse does not support these characters in the installation path. Error 1603 is received when Provisioning starts during the Upgrade process.

The issue is with Expeditor version 6.1.1 which ships with Lotus Notes 8 Standard Configuration. The application installs the Eclipse-java based features, also known as Provisioning. Expeditor 6.1.1 does not support installs to and from directories that have special characters including the $. This will result in the invalid directory location error that is seen in the install log file.

Expeditor 6.2 does support the $ and will be shipped as part of the upcoming Notes 8.5 client. Expeditor 6.2 was not available before Notes 8.0.2 was released.

Why does this only affect SMS?
It is not only SMS that is affected, but any vehicle that is used to automatically roll out the installs including Lotus Notes SmartUpgrade. SmartUpgrade will also have the same failure with $ if there is a link to the install in the SmartUpgrade Kit document. The Install Package can be attached to the upgrade kit document, and the upgrade will run normally.

The $ in the directory name is usually there to prevent the user from being able to browse the files in that directory while running the install. Since Expeditor 6.1.1 does not support the $, it fails to install the Notes 8 provisioning features.


Diagnosing the problem

The Install log will show the following entry:


MSI (s) (FC:C8) [16:52:10:871]: Doing action: CheckLocForValidCharsExec.5F3129E8_3AD4_4346_AEE6_A314E2DE64D9
Action ended 16:52:10:
SetDefaultProps.5F3129E8_3AD4_4346_AEE6_A314E2DE64D9. Return value 1.
MSI (s) (FC:98) [16:52:10:886]: Invoking remote custom action. DLL:
C:\WINDOWS\Installer\MSI4A.tmp, Entrypoint: CheckLocForValidCharsExec
Action start 16:52:10:
CheckLocForValidCharsExec.5F3129E8_3AD4_4346_AEE6_A314E2DE64D9.
MSI (s) (FC!F4) [16:52:11:011]: PROPERTY CHANGE: Adding
IS_VALID_LOCATION property. Its value is 'false'.
1: 10/13/2008 16:52:11 GenerateInfo/CheckLocationForValidCharsExecute:
ERROR - Invalid directory location:
//server/SMSPKGD$/HQ1001B9

The specified directory location cannot contain non-ASCII characters or
any of the following characters:

" ; | * ? < > ! # & $ ` , ' = ^ @

Property(S): TRANSFORMS = \\server\SMSPKGD$\HQ1001B9\Lotus Notes 8.0.2.mst Property(S): pluginCustomizationLocation =
//server/SMSPKGD$/HQ1001B9/deploy/plugin_customization.ini
Property(S): IS_VALID_LOCATION = false


Resolving the problem

This issue has been reported to Lotus Quality Engineering as SPR# LWLW79RA69, and is addressed in Expeditor 6.2.0, which ships with Notes 8.5.3.

Workarounds:
1. Do not use special characters in the install directory path
2. Use a different directory that does not include special characters
3. Configure SMS to first download the Installation Package to the local PC, and then install it vs running the install from the SMS distribution point.
4. If using SmartUpgrade, attach the Installation Package to the SmartUpgrade Kit Document.



Document information

More support for: IBM Notes
Install/Setup

Software version: 8.0, 8.5

Operating system(s): Windows

Reference #: 1326936

Modified date: 31 October 2011