IBM Support

How to reset the Administrator password in IBM ERM DOORS

Question & Answer


Question

How do you regain access to IBM DOORS when the Administrator user password is lost?

Cause

The option to change your password requires logging in to DOORS as 'Administrator' user.
When this information is lost or forgotten, you need to contact IBM DOORS Support team to reset the password credentials.

Answer

To reset your password: you need to start DOORS in a mode that generates a key code that you send to the DOORS Support to generate one-time password to enter in the login window.

WARNING: Do not use this procedure when your DOORS database properties have System usernames enabled. It is recommended you perform the procedure with DOORS Support engineer because the key code and password are session specific and cannot be reused.

Starting IBM DOORS with the command-line switch to generate a key that needs to log in with one-time password.

Note: Database administrators can control users' ability to reset the administrator's password.
Information regarding authorized user control is discussed in the Note section.

Steps to reset Administrator password

  1. Create a shortcut for DOORS.exe file on your desktop
     
  2. Right-click on the shortcut and select Properties
     
  3. Go to the SHORTCUT Tab of the Properties dialog box
     
  4. Scroll to the end of the Target field and left click after the closing quote
     
  5. Hit the Space Bar once then add -otdbpw ""

    Example:

    "C:\Program Files\IBM\Rational\DOORS\9.3\bin\doors.exe" -otdbpw ""

    Note: IBM DOORS administrators who want to control the authentication process to reset the Administrator user password can set the database password. When the database password is set and user attempts to reset the Administrators' password without providing database password, can result with message "invalid Password".
    When the database password is set by a DOORS administrator, that value needs to be included inside the quotes at the end of the switch. By default, the DOORS database password is not set. Use the DOORS Database Server Admin tool to set the database password; this prevents unauthorized users without knowledge of this information from resetting the Administrators password. Using this shortcut, the DOORS login window displays with an extra Key field
     
  6. Starting IBM DOORS from the shortcut displays the login window with the added Key field




    This encryption key information is then provided to support who can use it to generate a one-time password to be used in that login window

    Do not close this Login window; you need to type in one-time password provided by the Support
     
  7. When the one-time password is entered into the login window and you click OK, a dialog box is displayed with the message:
    "The password for user Administrator has expired, and must be changed before continuing"

    Image
  8. Click OK to close the message window and open the Change Password DOORS dialog box


     
  9. Supply a new password that meets your password requirements as defined in the DOORS database properties
     
Once the Administrator password is reset, the DOORS shortcut can be removed. Alternatively, you can delete the password reset switch and save the shortcut.


 

Legacy versions of IBM DOORS before 8.3 provided a UNIX-based client.


To reset the Administrator password on this platform:

  1. Start IBM DOORS and include the switch -otdbpw

    Example:

    doors -otdbpw port@host from $DOORSHOME/bin
     
  2. When DOORS launches, a key is generated in the login window
     
  3. Send the key to your IBM DOORS Support team exactly as it appears. Then, the Support can provide a temporary password to log in
 

For IBM DOORS 5.2

Follow the same steps without the use of quotes (as there is no database password to be set for this version of IBM DOORS). Although information about IBM DOORS 5.2 is included here, this version is no longer available. If you are using IBM DOORS 5.2, you need to upgrade to a supported version as soon as possible in order to receive support.

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Document Information

Modified date:
31 May 2023

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swg21324457