Technote (troubleshooting)
Problem(Abstract)
Attempts to access an IBM Rational Focal Point URL results in "HTTP Status 404 - /fp/servlet/Login error".
Symptom
The following error is returned when accessing a Focal Point URL after restoring a Focal Point 6.1 database backup on a new 6.1 installation:
"HTTP Status 404 - /fp/servlet/Login"
Cause
When the database is restored on a different Focal Point server, it tries to connect to the database on startup and sees that a server is already running. Since the database has not been setup in a clustered mode (standard install), it will not allow another connection as it thinks a node is already running.
Environment
This issue arises only for Focal Point backups running in a stand-alone installation and not a clustered/Load sharing mode.
Database backups are taken using scripts and this is done when the Focal Point server is running as it is not necessary to stop the server to take backups.
Resolving the problem
You need to remove the previous node entry for the database to start Focal Point as below.
- Stop Tomcat service / process for Focal Point
- Login to Postgres database
- pgAdminIII on Windows
- psql on a UNIX or Linux
- Execute the following SQL query
delete from node;
- Restart Tomcat process for Focal Point
- Login to Focal Point
Related information
A Japanese translation is available
Rate this page:
Copyright and trademark information
IBM, the IBM logo and ibm.com are trademarks of International Business Machines Corp., registered in many jurisdictions worldwide. Other product and service names might be trademarks of IBM or other companies. A current list of IBM trademarks is available on the Web at "Copyright and trademark information" at www.ibm.com/legal/copytrade.shtml.