I tried to install my process package but keep getting the error "A CRProcess Package is already installed"

Technote (FAQ)


Question

I tried to install my process package but keep getting the error "A CRProcess Package is already installed"

Answer

This can happen if a process package had previously failed to uninstall. The method to resolve this issue is to navigate to the "<cs_home>/cs_app/webapps/synergy/WEB-INF/wsconfig/system/" directory and delete or move the following files:

 


    cr_process_triggers.cfg

    cr_process_triggers.xml

    cr_process.xml


 
You will then need to stop and restart the Telelogic Change service (on windows) or the Jetty server (csctl.sh on UNIX).

 

Once the files have been deleted/moved, and the Change server restarted, you should be able to login again as an Admin and successfully install your process package.

Note: This FAQ is specific to Telelogic Change versions 4.4 or newer.

For Rational Change 5.1 and above

The method to resolve this issue is to navigate to the "<rc_home>/jetty/webapps/<context-name>/WEB-INF/wsconfig/system/" directory and delete or move the following file:

 

cr_process.xml

 
Then stop and restart the Rational Change service (on windows) or the Jetty server (csctl.sh on UNIX).

 Once the files have been deleted/moved, and the Change server restarted, you should be able to login again as an Admin and successfully install your process package.

Historical Number

10590

Rate this page:

(0 users)Average rating

Document information


More support for:

Rational Change
General Information

Software version:

4.6, 4.6.1, 4.7, 5.0, 5.1, 5.2, 5.2.0.1, 5.2.0.2, 5.2.0.3, 5.2.0.4, 5.2.0.5, 5.3, 5.3.0.1

Operating system(s):

AIX, HP-UX, Linux, Solaris, Windows

Reference #:

1323821

Modified date:

2011-09-28

Translate my page

Machine Translation

Content navigation