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Exception in WebSphere Application Server SystemOut.log file


Technote (troubleshooting)


Problem(Abstract)

There is an exception in the SystemOut.log file after installing the PlantsByWebSphere Sample application, and restarting WebSphere Application Server.

Symptom

If IBM WebSphere Application Server security is enabled, you will see the following exception in the <WAS Install Dir>/profiles/<profile name>/logs/<server name>/SystemOut.log file after installing the PlantsByWebSphere Sample application and restarting WebSphere Application Server:

UnixRegistryI E   SECJ0351E: Could not get the uniqueId of the user Everyone due to the following exception com.ibm.ws.security.registry.unix.UnixRegistryException: not a valid user

Cause

The messages in the log are caused by WebSphere Application Server attempting to assign the SampAdmin role to the Everyone user, which does not exist.

Resolving the problem

1. Run the following Jython command in the wsadmin command line tool:

    AdminApp.edit('PlantsByWebSphereEAR-1.1.1','[-MapRolesToUsers [["SampAdmin" Yes No "" ""]]]')
    AdminConfig.save()
2. Restart WebSphere Application Server.

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Document information

WebSphere Remote Server


Software version:
6.2, 6.2.1, 7.0, 7.1, 7.1.1


Operating system(s):
Linux


Reference #:
1323376


Modified date:
2010-06-29

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