IBM Support

How to troubleshoot IBM Rational Functional Tester

Question & Answer


Question

How do you troubleshoot errors that can occur when using IBM Rational Functional Tester (RFT)?

Cause

What questions do you need to ask and what information do you need to gather in order to start trouble shooting in issue with RFT?

Answer

Troubleshooting Guide

The following sections provide a guide for identifying and troubleshooting errors that can occur when using Rational Functional Tester. Use these steps to troubleshoot problems you might experience and provide this data to Rational Functional Tester support for further assistance if needed.

Environmental information

Crucial Environmental information to be collected in initial contact

Problem Space Description:

  1. Rational Functional Tester specific information
    1. Which RFT domain is it? (HTML, Java, .Net, Win32, SAP, Siebel, Flex, FTE)
    2. What is the RFT build number?
    3. Windows OS / Linux OS version information including Service Pack?
      1. Is it supported by the version of Rational Functional Tester?
  2. What type of application under test is it?
    1. An HTML application
    2. A Java application
    3. .NET app
    4. Win32 app
    5. SAP app
    6. Siebel app
    7. Flex app
  3. Other scenarios?
    1. What is the build/run-time environment?
    2. Visual Studio version(s)?
    3. Java/JRE/JDK Version(s) on the test machine?
    4. JRE Version(s) required by AUT?
    5. .NET Framework version(s)?

Identifying the situation

What exactly is the issue with RFT?
  1. Installation is failing?
  2. Browser test is not passing?
    1. Not able to recognize the controls?
  3. Script playback is not working as expected?
    1. Failing at a particular point?
    2. Failing at starting itself?
    3. Passing with warning?
    4. Something else?
  4. Playback log is not coming after playback is complete?
  5. Verification point comparator is not opening?
  6. Execution of RFT scripts from CQTM/TM is not happening?
  7. RFT Scripts from CC are not playing back?
  8. Scripts fail during long runs?
  9. Not able to create a script in VS IDE?
  10. AUT / RFT crashed while recording or playback?
  11. AUT / RFT hangs while recording or playback?
  12. Memory dump during recording or playback?
  13. Unable to playback old scripts upon updating RFT from 7.0.0 to 7.0.1.2
  14. Unable to playback RFT scripts on remote agent machines
  15. RFT scripts run slow on IE v7.0 (known issue but no solution yet)

Basic Troubleshooting

Basic Troubleshooting
  1. Make sure browser test passes by:
    1. Installing a separate JRE (apart from the JRE, which comes with RFT).
    2. Make this new JRE as system JRE while installing.
    3. Enable this JRE in RFT-enabler.
    4. Enable the browser.
    5. Test the browser.
  2. Make sure correct JRE is enabled by
    1. Enabling a JRE which is used by the AUT.
    2. Enabling a JRE using which the app is compiled.
  3. For execution using TM/CQTM
    1. Make sure that .testsuite file is getting generated after script compilation.
    2. If .testsuite is not getting generated then rename/delete the .metadata file and start eclipse from command line with –clean option.
    3. Make sure the environment is setup correctly on both local and remote machine (in case of remote execution)
  4. For execution of scripts from ClearCase
    1. Make sure that .class files are correctly generated after connecting to the project in CC.
    2. If playback still fails then check out and rebuild all the assets and then playback.
  5. If playback of the scripts fail with Object Not Found Exception or pass with Warnings:
    1. Record the same test case twice in 2 different sessions of the application.
    2. Compare the object maps and see if there is any value of any recognition property of any object (in the object map) differs in two object maps.
    3. Replace the “changing value” with a suitable regular expression and then playback the script.
  6. If the recording against Siebel application is not happening correctly
    1. Make sure STA (Siebel Test Automation) process is running in the Task Manager.
    2. If STA is not running then contact your Siebel Administrator to run the following command on server machine: change parameter EnableAutomation=True for server server_name comp comp_name
    3. Reboot the Siebel server.
  7. Refer RFT’s help contents for any other issue.
  8. Refer to the RFT Information Center for any other issue.

Advanced Troubleshooting

Advanced Troubleshooting

For any issue related to crash/hang/Memory dump/Performance

  1. Bring up ivory.properties.
  2. Set following flags to “true”:
    1. rational.test.ft.debug.enabled=false
    2. rational.test.ft.debug.native_to_file=false
  3. Modify rational.test.ft.debug.filter=default,1; to rational.test.ft.debug.filter=default,3;
  4. Repeat the use case of crash/hang/Memory dump/Performance and stop recording.
  5. Get the ivorydebug.txt file and pass it on to RFT team.
  6. IBM Support Assistant

[{"Product":{"code":"SSJMXE","label":"IBM Rational Functional Tester"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"General Information","Platform":[{"code":"PF033","label":"Windows"}],"Version":"7.0;7.0.1;8.0;8.1;8.1.1;8.2;8.3;8.5","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21320842