AppScan Standard stops and displays an "AppScan has reached its predefined memory limit" message

Technote (troubleshooting)


Problem(Abstract)

Upon reaching its memory limit, IBM Rational AppScan Standard stops and displays the following message "AppScan has reached its predefined memory limit".

Cause

AppScan Standard stops due to increased memory usage.

Diagnosing the problem

If you continue scanning AppScan Standard *may* crash and lose all the data.

Resolving the problem

Workaround for AppScan Standard version 8.5 and older:

To prevent AppScan from stopping due to excessive memory usage, you can set up AppScan to restart automatically when memory usage becomes too high.

When the scan ends due to low virtual memory, AppScan checks if it was configured in the registry to be restarted.

Set Tools > Options > Advanced > PerformanceMonitor.RestartOnOutOfMemory, to True if you want to turn this on.

Also, set Tools > Options > Advanced > PerformanceMonitor.MinScanTimeDurationForRestart to the number of minutes AppScan should have run before it reached the memory problem.


After seting RestartOnOutOfMemory to true, AppScan will now perform as follows:

  • Compare it to its current run, this is the number of minutes the Rational AppScan instance ran, not the overall scan time.
  • Check if the scan has a name, and saves it.
  • Check if the users last action was fullscan/explore/test.
  • Start a new Rational AppScan session while loading the saved scan and resume the user's last action.
  • Close the instance of Rational AppScan that consumed to much memory.

Ensure in both versions that 'Automatically save during scan' option is enabled under Scan Monitoring in Tools > Options > Scan Options tab.

Related information

A simplified Chinese translation is available

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Document information


More support for:

Security AppScan Standard
Configuration

Software version:

8.0, 8.5

Operating system(s):

Windows

Software edition:

Express, Standard

Reference #:

1317833

Modified date:

2014-03-10

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