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Mapped network drives in Windows are not visible to WebSphere Application Server

Troubleshooting


Problem

IBM® WebSphere® Application Server might not be able to locate mapped network drives in Microsoft® Windows® under certain circumstances.

Cause

Due to how permissions are assigned to mapped network drives, not all users are able to access these drives by way of the drive letters. Only the services owned by the Local System Account can map network drives that can be seen by all other accounts.

Resolving The Problem

Normal user accounts, including Administrators, can create mapped drives and assign them drive letters (Z:\); however, they are the only user to see these drives. Processes started by this user are able to see this mapped drive.

However, if that same user starts a Windows Service, that service is unable to see the mapped drive. Only services owned by the Local System Account can map network drives that can be seen by all other accounts.

 
WebSphere Application Server as a nonservice
If WebSphere Application Server is set up to run as a nonservice, such as from the command line, the user starting the server (or the user who started the nodeagent) must be the same user who mapped the network drive. This section also applies to the Liberty Profile.
 
Example:
Two user accounts are created, named admin and wasuser.
WebSphere Application Server is not configured to run as a service.
  • "admin" is an Administrator.
    • "admin" creates a mapped network drive Z:\ and points it to \\network\folder\
  • "wasuser" is a Power User.
    • "wasuser" has permissions to launch WebSphere Application Server from the command line.

If any application on the server connects directly to drive Z:\, it isn't found. "wasuser" did not map drive Z:\.


Either method can be used to resolve this issue:
  1. Use the Universal Naming Convention (UNC) path in the application to access the shared network location.
    • In the example, the application connects to \\network\folder\ instead of Z:\
       
  2. Map the drives so that they are associated with the user account that starts WebSphere Application Server.
    • In the example, "wasuser" would need to map drive Z:\ to \\network\folder\ in order for that drive to become available.
 
WebSphere Application Server as a Windows Service
On Windows, normally WebSphere Application Server is created as a Windows Service. A service that is configured to run under a specific user account will always create a new log-on session to launch the service. Any mapped drives created by the same user account is unavailable as they are not mapped during the same log-on session as the service.

On Windows Vista, Windows 7, Windows 2008, and later, you may see similar behavior when the User Account Control (UAC) elevates permissions. When this occurs and the account is elevated, this also ends up creating a new authentication ID and thus previous mapped drives by the non-elevated user are not visible.

The solution in this case is to stop using the mapped network drives letters and instead use UNC paths.
If using UNC paths is not possible, either disable or remove the Windows Service, then follow the directions in the previous section:

To disable the service:
  1. Click on Start > Run...
  2. Type the command services.msc and click OK.
  3. Locate the service associated with the application server (or nodeagent) and double-click the entry.
  4. Under the Startup Type drop-down box, choose Disabled.
  5. Click OK.

To remove the service:
WASService.exe -remove [SERVICE_NAME]
Where [SERVICE_NAME] is the name of the Windows Service.
  1. Stop the server.
  2. Open a command prompt and navigate to the install_root/bin directory.
  3. Run the following command:
     
  4. Start the server.

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Document Information

Modified date:
07 July 2022

UID

swg21316456