Mail Send agents fail with ambiguous name error after upgrade to Notes 8

Technote (FAQ)


Question

After upgrading Lotus Notes to 8.x, Mail Send agents that had worked in previous releases of Notes now fail with an ambiguous name error. An example of such an error is shown below.


    "Unable to send mail, multiple matches found in Name & Address Book(s)".

This issue may also occur when using standard Notes databases that include mail sending options,
such as the review cycle feature in the MS Office Library template of Notes. These templates may display their own error message when code to send mail fails. An example of such an error is:

"FYI: John Doe could not be notified by email at this time."


Steps to reproduce
1. Open a message from a user in your domain (e.g., John Doe/MyDomain)

2. The Recent Contacts view (also known as the Dynamic Personal Address Book or DPAB) is automatically updated with an entry for this user.

3. Select Tools > Add Sender to Address Book. The user is added to the Contacts view of the personal address book.

4. Create an agent that sends mail to this user, use the First Name and Last Name of this user in the SendTo field set by the agent, e.g. John Doe. Set the agent to run from the Action menu. Set the target as none.

Here is an example of such an agent

Sub Initialize
Dim session As New NotesSession
Dim db As NotesDatabase
Dim doc As NotesDocument
Set db = session.CurrentDatabase
Set doc = New NotesDocument( db )
doc.Form = "Memo"
doc.SendTo = "John Doe"
doc.Subject = "Testing a mail agent. Here's a document for you to delete. Thanks!!!"
Call doc.Send( False )
End Sub

5. Run the agent.

6. An error occurs "Unable to send mail, multiple matches found in Name & Address Book(s)", and the mail is not sent.



Cause

This error occurs because the Recent Contacts view and Contacts view in the Notes client contain an entry with the same name.

Answer

This issue is fixed in 8.0.2 Fix Pack 1.


Fix details: SPR# PJON7DTPXK

Refer to the Upgrade Central site for details on upgrading Notes/Domino.



Workarounds
You can work around this issue by modifying the agent that sends mail, or by clearing the Recent Contacts view and disabling future updates of that view.

For a workaround that can be implemented in the code that sends the mail, refer to the following document:

-- Document #1153854, "Error: 'Unable to send mail...' when using LotusScript Send method"

For information on clearing the Recent Contacts view and disabling future updates of the view, refer to the following documents:

-- Document #1267115, "Is there a way to disable the Notes 8 Recent Contacts feature?"

-- Document #1395526, "Understanding Notes 8.x Recent Contacts (Q&A, Related Content, and Enhancement Requests)"


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Document information


More support for:

IBM Notes
Mail

Software version:

8.0

Operating system(s):

Windows

Software edition:

Edition Independent

Reference #:

1316108

Modified date:

2010-02-15

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