IBM InfoSphere Information Server, Version 8.1, system requirements

Preventive Service Planning


Abstract

This document includes system requirements for the product modules and components of IBM InfoSphere Information Server.

Content

Tab navigation

Ensure that your computer meets the system requirements before you install the InfoSphere Information Server suite product modules and components.



System requirements (Windows)


Before you install InfoSphere Information Server in a Microsoft Windows environment, ensure that your computer meets the hardware and software requirements for the product modules and components that you want to install.

Platform requirements (Windows)


The client tier is supported on 32-bit versions of the following operating systems:

  • Windows XP Professional. Service Pack 2 is required.
  • Windows Vista. You can use any of these editions: Windows Vista Business, Windows Vista Ultimate, or Windows Vista Enterprise.
  • Windows 7. You can use any of these editions: Windows 7 Professional, Windows 7 Enterprise, or Windows 7 Ultimate.
  • Windows Server 2003. Service Pack 2 is required. You can use any of these editions: Windows Server 2003 Standard, Windows Server 2003 Enterprise, Windows Server 2003 Datacenter, Windows Server 2003 R2 Standard, Windows Server 2003 R2 Enterprise, or Windows Server 2003 R2 Datacenter.

The metadata repository, services, and engine tiers are supported on the 32-bit version of Windows Server 2003.

Note: To use more than 4 GB of RAM, Windows Server 2003 Enterprise, Windows Server 2003 R2 Enterprise, Windows Server 2003 Datacenter, or Windows Server 2003 R2 Datacenter is required.

All InfoSphere Information Server products are supported on all tiers on the 32-bit Windows operating systems specified above when running on 32-bit or 64-bit AMD or Intel processors.

For information about support for IBM software products running in a VMware environment, go to www.ibm.com/support/docview.wss?&uid=wws1e333ce0912f7b152852571f60074d175.

Client tier software requirements (Windows)


Ensure that your computer meets the client software requirements before you install the client tier.

IBM InfoSphere Information Server console

Your system must have Microsoft .NET Framework 1.1 with Service Pack 1 installed. The InfoSphere Information Server installation program installs Microsoft .NET Framework 1.1 with Service Pack 1 when there is not an existing installation of Microsoft .NET Framework 1.1.

Note: You must upgrade existing installations of .NET Framework 1.1 to .NET Framework 1.1 Service Pack 1.

IBM InfoSphere Information Server Web console

The following Web browsers are supported:

  • Microsoft Internet Explorer 6 Service Pack 2
  • Microsoft Internet Explorer 7
  • Mozilla Firefox 2

IBM InfoSphere Information Server Business Glossary Anywhere

  • Internet Explorer 7 (Business Glossary Anywhere is not browser-based, but uses components that are provided by Internet Explorer 7)
  • Microsoft .NET Framework 2 Service Pack 1

IBM InfoSphere Business Glossary Client for Eclipse The InfoSphere Business Glossary Client for Eclipse is supported on Microsoft Windows XP, Service Pack 2.

The computers must meet the following requirements:

  • Network connectivity to an instance of InfoSphere Business Glossary, Version 8.1.2.
  • Java™ Runtime Environment (JRE) version 1.6.
  • Depending on which Eclipse features of the InfoSphere Business Glossary Client you want to install, the system must have the following software prerequisites installed:
    • InfoSphere Business Glossary Core: supported on any Eclipse application based on Eclipse 3.4.2 or Eclipse 3.5.1
    • InfoSphere Business Glossary UML Integration: supported on Rational Software Architect version 7.5.2
    • InfoSphere Business Glossary UML Profile: supported on Rational Software Architect family products, version 7.5.2 and InfoSphere Data Architect version 7.5.2
    • InfoSphere Business Glossary Data Model Integration: supported on InfoSphere Data Architect, Version 7.5.2 Fix Pack 1 or InfoSphere Data Architect, Version 7.5.2 Fix Pack 2. The InfoSphere Data Architect installation must include the Lifecycle and Architecture Tool Integration, UML-to-LDM Transformation feature.

Metadata repository tier and InfoSphere Information Analyzer analysis database software requirements (Windows)


The following database servers are supported for use with the metadata repository and the InfoSphere Information Analyzer analysis database:

  • IBM DB2 Enterprise Server Edition Version 9.1 or a subsequent fix pack for this version
  • IBM DB2 Enterprise Server Edition Version 9.5 Fix Pack 2a or a subsequent fix pack for this version
  • Microsoft SQL Server 2005 Enterprise Edition
  • Oracle 10g Release 2
  • Oracle 11g Release 1
  • Oracle 11g Release 2

The database server must be installed on the same computer that the services tier is installed on, or on another computer with high-speed network connectivity to the services tier computer. This requirement might not be met when the computers are not on the same network segment or if a firewall is installed between the two computers.

When you install InfoSphere Information Server, you can have the InfoSphere Information Server installation program install a new copy of DB2 Version 9.5, or you can use an existing DB2 Version 9.1 or DB2 Version 9.5 installation.

Note:

  • Oracle Advanced Security option is not supported. If this option is turned on, turn it off before installing Version 8.1.
  • For DB2 instances, partitioned databases are not supported.
  • DB2 is not required if you are using another database server for the metadata repository database or the InfoSphere Information Analyzer analysis database.

Services tier software requirements (Windows)


WebSphere Application Server Version 6.0.2 fix pack 27 or a subsequent fix pack for this version is required for the services tier. When you install InfoSphere Information Server, you can install WebSphere Application Server, or you can use a preexisting WebSphere Application Server installation.

IBM InfoSphere Information Server FastTrack

The metadata import process requires that at least one of the following components be installed on the services and engine tiers when you install IBM InfoSphere Information Server FastTrack on the client tier:

  • IBM InfoSphere DataStage and IBM InfoSphere QualityStage
  • InfoSphere Information Analyzer

Engine tier software requirements (Windows)


One of the following C++ compilers is required for InfoSphere QualityStage and InfoSphere DataStage when you use the parallel canvas. The parallel canvas requires that the compiler and the SDK be installed in their default locations.

  • Microsoft Visual C++ .NET 2003
  • Microsoft Visual Studio 2005 Professional Edition C++
  • Microsoft Visual Studio .NET 2005 Express™ Edition C++

Documentation software requirements (Windows)


To access help and other topics in the InfoSphere Information Server Version 8.1 information center, which is installed in the services tier, you must have one of the supported Web browsers installed. The following Web browsers are supported:

  • Microsoft Internet Explorer 6
  • Microsoft Internet Explorer 7
  • Mozilla Firefox Version 2

To access the PDF documentation that is installed with InfoSphere Information Server, you must have Adobe Acrobat or a comparable PDF reader installed.

Networking requirements (Windows)


The client, metadata repository, services, and engine tiers must be able to communicate with each other over the network on all ports that are used by the software.

Memory requirements (Windows)


  • The minimum amount of memory for installing the InfoSphere Information Server client tier is 2 GB.
  • The minimum amount of memory for installing the InfoSphere Information Server services and engine tiers on the same computer, or on separate computers, is 4 GB.

Memory requirements depend on the type of processing, the volume of parallel processing, the size and number of simultaneously running InfoSphere DataStage and InfoSphere QualityStage jobs, and the memory requirements of the operating system and other applications (such as relational databases).

Evaluate the following factors to determine the memory requirements for your system:

  • The number of InfoSphere Information Server product components on the same server
  • Other software on the same server
  • Performance requirements
  • Size and complexity of your configuration
  • Extent of activity and the number of concurrent clients that access your system

Minimum disk space requirements (Windows)


Important: These installation disk space requirements are the minimum requirements for installation. Operational requirements are significantly larger than these minimum installation disk space requirements.

The installation of InfoSphere Information Server requires the following minimum disk space:

  • 1.3 GB for WebSphere Application Server
  • 500 MB for DB2
  • 1.4 GB for the InfoSphere Information Server components
  • 2.5 GB for the metadata repository database
  • 1 GB for the InfoSphere Information Analyzer analysis database
  • 2 GB of temporary space during the installation

Note: Your system's temporary directory requires 1 GB of available free space during installation, even when you specify an alternate location for the InfoSphere Information Server installation program to use for temporary storage during installation.

Table 1. Minimum disk space requirements for a client tier installation

Client products and components Minimum disk space
InfoSphere Information Server client products
  • 10 MB in the Windows\system32\ directory
  • 840 MB
IBM InfoSphere Information Server Business Glossary Anywhere 3 MB

Table 2. Minimum disk space requirements for the metadata repository tier installation

Metadata repository components Minimum disk space
DB2 500 MB
Metadata repository database DB2: 2.5 GB
Oracle: 1 GB
SQL Server: 1.2 GB
InfoSphere Information Analyzer analysis database 1 GB

Table 3. Minimum disk space requirements for the services tier installation

Services components Minimum disk space
WebSphere Application Server 1.3 GB
InfoSphere Information Server product components 310 MB

Table 4. Minimum disk space requirements for the engine tier installation

Engine components Minimum disk space
InfoSphere Information Server product components 700 MB

Table 5. Disk space requirements for the documentation installation

Documentation component Disk space
PDF documentation 400 MB

System requirements (Linux, UNIX)


The metadata repository, services, and engine tiers are supported on systems that run the following versions of Linux and UNIX.

Table 6. Linux and UNIX operating systems

Operating system 32-bit or 64-bit Processors and environments
HP-UX 11i v2 64-bit PA-RISC
HP-UX 11i v3 64-bit PA-RISC
HP-UX 11i v2 64-bit Intel Itanium processors
HP-UX 11i v3 64-bit Intel Itanium processors
IBM AIX 5.3 64-bit - RISC (POWER5, POWER6, and POWER7) processors. Additional requirements apply to POWER7. See technotes 142150 and 1420730.
- Logical partitions are supported
IBM AIX 6.1 64-bit - RISC (POWER5, POWER6, and POWER7) processors. Additional requirements apply to POWER7. See technotes 142150 and 1420730.
- Logical partitions are supported
Red Hat Enterprise Linux 4 Server 32-bit or 64-bit AMD or Intel processors
Red Hat Enterprise Linux 4 Advanced Platform 32-bit or 64-bit AMD or Intel processors
Red Hat Enterprise Linux 5 Server 32-bit or 64-bit AMD or Intel processors
Red Hat Enterprise Linux 5 Advanced Platform 32-bit or 64-bit AMD or Intel processors
Red Hat Enterprise Linux 5 Server 64-bit IBM System z
Red Hat Enterprise Linux 5 Advanced Platform 64-bit IBM System z
Sun Solaris 9 Operating Environment 64-bit UltraSPARC processors
Sun Solaris 10 Operating Environment 64-bit - UltraSPARC processors
- Solaris Zones and Solaris Containers are supported
SUSE Linux Enterprise Server 10 32-bit or 64-bit - Service Pack 1
- AMD or Intel processors
SUSE Linux Enterprise Server 10 64-bit IBM System z

For information about support for IBM software products running in a VMware environment, go to www.ibm.com/support/docview.wss?&uid=wws1e333ce0912f7b152852571f60074d175.

Package requirements (Linux, UNIX)


Ensure that your system has the required minimum packages for your installation mode and your installation topology before you install IBM InfoSphere Information Server.

AIX

The following package requirement applies to installations on AIX systems.

  • The Asynchronous I/O Extension AIO package is required for AIX 5.3 and AIX 6.1 installations when DB2 is the database server for IBM InfoSphere Information Server.

32-bit Red Hat Enterprise Linux 4 Server on x86

The package requirements for 32-bit Red Hat Enterprise Linux 4 Server on x86 are defined in the following table.

Table 7. Package requirements for 32-bit Red Hat Enterprise Linux 4 Server on x86

Required package name Graphical installation Services tier Console installation, silent installation, or engine tier Preinstalled DB2 9.1
compat-db-4.1.25-9 Not required 32-bit Not required Not required
compat-libstdc++-33-3.2.3-47.3 Not required 32-bit 32-bit 32-bit
glibc-2.3.4-2.9 32-bit 32-bit 32-bit Not required
libgcc-3.4.6-8 32-bit 32-bit 32-bit Not required
libstdc++-3.4.6-8 32-bit 32-bit 32-bit Not required
rpm-build-4.3.3-7_nonptl Not required 32-bit Not required Not required
xorg-x11-libs-6.8.2-1.EL.13.6 32-bit 32-bit Not required Not required
xorg-x11-deprecated-libs-6.8.2-1.EL.13.6 32-bit 32-bit Not required Not required

64-bit Red Hat Enterprise Linux 4 Server on x86_64

Both 32-bit packages and 64-bit packages are required for 64-bit Red Hat Enterprise Linux Advanced 4 Server on x86_64. The package requirements are defined in the following table.

Table 8. Package requirements for 64-bit Red Hat Enterprise Linux 4 Server on x86_64

Required package name Graphical installation Services tier Console installation, silent installation, or engine tier DB2 9.5
compat-db-4.1.25-9 Not required 32-bit and 64-bit Not required Not required
compat-libstdc++-296-2.96-132.7.2 Not required 64-bit Not required Not required
compat-libstdc++-33-3.2.3-47.3 Not required 32-bit and 64-bit 32-bit and 64-bit 64-bit
glibc-2.3.4-2.9 32-bit 64-bit 32-bit Not required
glibc-devel-32bit-2.4-31.61 64-bit 64-bit 64-bit 64-bit
libaio Not required Not required Not required 64-bit
libgcc-3.4.6-8 32-bit 32-bit 32-bit Not required
libstdc++-3.4.6-8 32-bit 64-bit 32-bit Not required
rpm-build-4.3.3-7_nonptl Not required 64-bit Not required Not required
xorg-x11-libs-6.8.2-1.EL.13.6 32-bit 64-bit Not required Not required
xorg-x11-deprecated-libs-6.8.2-1.EL.13.6 32-bit 32-bit and 64-bit Not required Not required

32-bit Red Hat Enterprise Linux 5 Advanced Platform on x86

The package requirements for 32-bit Red Hat Enterprise Linux 5 Advanced Platform on x86 are defined in the following table.

Table 9. Package requirements for 32-bit Red Hat Enterprise Linux 5 Advanced Platform on x86

Required package name Graphical installation Services tier Console installation, silent installation, or engine tier Preinstalled DB2 9.1
compat-db-4.2.52-5.1 Not required 32-bit Not required Not required
compat-libstdc++-33-3.2.3-61 Not required 32-bit Not required 32-bit
compat-libstdc++-296-2.96-138 Not required 32-bit Not required Not required
elfutils-0.125-3.el5 Not required 32-bit Not required Not required
elfutils-libs-0.125-3.el5 Not required 32-bit Not required Not required
glibc-2.5-24 32-bit 32-bit 32-bit Not required
libgcc-4.1.2-42.el5 32-bit 32-bit 32-bit Not required
libstdc++-4.1.2-42.el5 32-bit 32-bit 32-bit Not required
libXmu-1.0.2-5 32-bit 32-bit Not required Not required
libXt-1.0.2-3.1.fc6 32-bit 32-bit Not required Not required
libX11-1.0.3-9.el5 32-bit 32-bit Not required Not required
libXtst-1.0.1-3.1 32-bit 32-bit Not required Not required
libXp-1.0.0-8.1.el5 32-bit 32-bit Not required Not required
libXext-1.0.1-2.1 32-bit 32-bit Not required Not required
libSM-1.0.1-3.1 32-bit 32-bit Not required Not required
libICE-1.0.1-2.1 32-bit 32-bit Not required Not required
libXau-1.0.1-3.1 32-bit 32-bit Not required Not required
libXdmcp-1.0.1-2.1 32-bit 32-bit Not required Not required
pam-0.99.6.2-3.26.el5 32-bit 32-bit Not required Not required

64-bit Red Hat Enterprise Linux 5 Advanced Platform on x86_64

Both 32-bit packages and 64-bit packages are required for 64-bit Red Hat Enterprise Linux 5 Advanced Platform on x86_64. The package requirements are defined in the following table.

Table 10. Package requirements for 64-bit Red Hat Enterprise Linux 5 Advanced Platform on x86_64

Required package name Graphical installation Services tier Console installation, silent installation, or engine tier DB2 9.5
compat-db-4.2.52-5.1 Not required 32-bit and 64-bit 32-bit and 64-bit Not required
compat-libstdc++-33-3.2.3-61 Not required 32-bit and 64-bit 32-bit and 64-bit 64-bit
elfutils-0.125-3.el5 Not required 64-bit Not required Not required
elfutils-libs-0.125-3.el5 Not required 64-bit Not required Not required
glibc-2.5-24 32-bit 64-bit 32-bit 64-bit
libaio-0.3.105-2 Not required Not required Not required 64-bit
libgcc-4.1.2-42.el5 32-bit 32-bit 32-bit 64-bit
libstdc++-4.1.2-42.el5 32-bit 64-bit 32-bit 64-bit
libXmu-1.0.2-5 32-bit 32-bit and 64-bit Not required Not required
libXt-1.0.2-3.1.fc6 32-bit 64-bit Not required Not required
libX11-1.0.3-9.el5 32-bit 64-bit Not required Not required
libXtst-1.0.1-3.1 32-bit 32-bit and 64-bit Not required Not required
libXp-1.0.0-8.1 32-bit 32-bit and 64-bit Not required Not required
libXext-1.0.1-2.1 32-bit 64-bit Not required Not required
libSM-1.0.1-3.1 32-bit 64-bit Not required Not required
libICE-1.0.1-2.1 32-bit 64-bit Not required Not required
libXau-1.0.1-3.1 32-bit 64-bit Not required Not required
libXdmcp-1.0.1-2.1 32-bit 64-bit Not required Not required
pam-0.99.6.2-3.26.el5 Not required 32-bit and 64-bit Not required Not required

64-bit Red Hat Enterprise Linux 5 Advanced Platform on IBM System z

Both 32-bit packages and 64-bit packages are required for 64-bit Red Hat Enterprise Linux 5 Advanced Platform on IBM System z. The package requirements are defined in the following table.

Table 11. Package requirements for 64-bit Red Hat Enterprise Linux 5 Advanced Platform on IBM System z

Required package name Graphical installation Services tier Console installation, silent installation, or engine tier DB2 9.5
compat-libstdc++-295-2.95.3-85 Not required 32-bit and 64-bit 32-bit and 64-bit 64-bit
compat-libstdc++-33-3.2.3-61 Not required 32-bit and 64-bit Not required 64-bit
elfutils-0.125-3.el5 Not required 64-bit Not required Not required
elfutils-libs-0.125-3.el5 Not required 64-bit Not required Not required
glibc-2.5-18 32-bit 64-bit 32-bit 64-bit
libaio-0.3.106-3.2 Not required Not required Not required 64-bit
libgcc-4.1.2-14.el5 32-bit Not required 32-bit Not required
libICE-1.0.1-2.1 32-bit 64-bit Not required Not required
libSM-1.0.1-3.1 32-bit 64-bit Not required Not required
libstdc++-4.1.2-14.el5 32-bit Not required 32-bit Not required
libX11-1.0.3-9.el5 32-bit 64-bit Not required Not required
libXau-1.0.1-3.1 32-bit 64-bit Not required Not required
libXdmcp-1.0.1-2.1 32-bit 64-bit Not required Not required
libXext-1.0.1-2.1 32-bit 64-bit Not required Not required
libXmu-1.0.2-5 32-bit 32-bit and 64-bit Not required Not required
libXp-1.0.0-8.1.el5 32-bit 32-bit and 64-bit Not required Not required
libXt-1.0.2-3.1.fc6libXt-1.0.2-3.1.fc6 32-bit 64-bit Not required Not required
libXtst-1.0.1-3.1 32-bit 32-bit and 64-bit Not required Not required
pam-0.99.6.2-3.26.el5 Not required 32-bit and 64-bit Not required Not required

32-bit SUSE Linux Enterprise Server 10 on x86

The package requirements for 32-bit SUSE Linux Enterprise Server 10 on x86 are defined in the following table.

Table 12. Package requirements for 32-bit SUSE Linux Enterprise Server 10 on x86

Required package name Graphical installation or service tier Console installation, silent installation, or engine tier Preinstalled DB2 9.1
compat-libstdc++-5.0.7-22.2 Not required Not required 32-bit
glibc-2.4-31.2 32-bit 32-bit Not required
libgcc-4.1.0-28.4 32-bit 32-bit Not required
libstdc++-4.1.0-28.4 32-bit 32-bit Not required
xorg-x11-libs-6.9.0-50.14 32-bit Not required Not required

64-bit SUSE Linux Enterprise Server 10 on x86_64

Both 32-bit packages and 64-bit packages are required for 64-bit SUSE Linux Enterprise Server 10 on x86_64. The package requirements are defined in the following table.

Table 13. Package requirements for 64-bit SUSE Linux Enterprise Server 10 on x86_64

Required package name Graphical installation or service tier Service tier Console installation, silent installation, or engine tier DB2 9.5
compat-libstdc++-5.0.7-22.2 Not required Not required 64-bit 64-bit
glibc-2.4-31.2 32-bit 64-bit 32-bit and 64-bit Not required
glibc-devel-32bit-2.4-31.61 64-bit 64-bit 64-bit 64-bit
libaio-0.3.104-14.2 Not required Not required Not required 64-bit
libgcc-4.1.0-28.4 32-bit 32-bit 32-bit and 64-bit Not required
libstdc++-4.1.0-28.4 32-bit 32-bit 32-bit Not required
xorg-x11-libs-6.9.0-50.14 32-bit 64-bit Not required Not required

64-bit SUSE Linux Enterprise Server 10 on IBM System z

Both 32-bit packages and 64-bit packages are required for 64-bit SUSE Linux Enterprise Server 10 on IBM System z. The package requirements are defined in the following table.

Table 14. Package requirements for 64-bit SUSE Linux Enterprise Server 10 on IBM System z

Required package name Graphical installation or service tier Service tier Console installation, silent installation, or engine tier DB2 9.5
compat-libstdc++-5.0.7-22.2 Not required Not required 64-bit 64-bit
glibc-2.4-31.2 32-bit 64-bit 32-bit 64-bit
glibc-devel-32bit-2.4-31.61 64-bit 64-bit 64-bit 64-bit
libaio-0.3.104-14.2 Not required Not required Not required 64-bit
libgcc-4.1.0-28.4 32-bit Not required Not required Not required
libstdc++-4.1.0-28.4 32-bit 64-bit 32-bit Not required
xorg-x11-libs-6.9.0-50.14 32-bit 64-bit Not required Not required

Metadata repository tier and InfoSphere Information Analyzer analysis database software requirements (Linux, UNIX)


The following database servers are supported for use with the metadata repository and the InfoSphere Information Analyzer analysis database:

  • IBM DB2 Enterprise Server Edition Version 9.1 or a subsequent fix pack for this version
  • IBM DB2 Enterprise Server Edition Version 9.5 Fix Pack 2a or a subsequent fix pack for this version
  • IBM DB2 for z/OS Version 9.1 or a subsequent fix pack for this version
  • Oracle 10g Release 2
  • Oracle 11g Release 1
  • Oracle 11g Release 2

Note:

  • For DB2 instances, partitioned databases are not supported.
  • DB2 is not required if you are using another database server for the metadata repository database or the InfoSphere Information Analyzer analysis database.
  • DB2 for z/OS is supported only for InfoSphere Information Server installations on Red Hat Enterprise Linux 5 on IBM System z and SUSE Linux Enterprise Server 10 on IBM System z.
  • Oracle Advanced Security is not supported. If this option is turned on, turn it off before installing Version 8.1.

The database server must be installed on the same computer that the services tier is installed on, or on another computer with high-speed network connectivity to the services tier computer. This requirement might not be met when the computers are not on the same network segment or if a firewall is installed between the two computers.

When you install IBM InfoSphere Information Server, you can have the IBM InfoSphere Information Server installation program install a new copy of DB2 Version 9.5, or you can use an existing DB2 Version 9.1 or DB2 Version 9.5 installation. You must ensure that your computer meets the database installation requirements for your operating system.

Table 15. Installation options for DB2 database system

Operating system Installed with IBM Information Server Preinstalled supported
HP-UX on PA-RISC DB2 Version 9.1 DB2 Version 9.1
HP-UX on Intel Itanium DB2 Version 9.5 DB2 Version 9.5 or DB2 Version 9.1
IBM AIX DB2 Version 9.5 DB2 Version 9.5 or DB2 Version 9.1
32-bit Red Hat Linux None DB2 Version 9.1
64-bit Red Hat Linux DB2 Version 9.5 DB2 Version 9.5 or DB2 Version 9.1
Solaris DB2 Version 9.5 DB2 Version 9.5 or DB2 Version 9.1
32-bit SUSE Linux Enterprise Server 10 None DB2 Version 9.1
64-bit SUSE Linux Enterprise Server 10 DB2 Version 9.5 DB2 Version 9.5 or DB2 Version 9.1

Note: DB2 Version 9.5 is not supported on 32-bit Linux operating systems. To use DB2 on 32-bit operating systems, you must preinstall DB2 Version 9.1.

The following requirements apply to HP-UX on PA-RISC operating systems when DB2 Version 9.1 is the database server on the metadata repository tier.

  • HP-UX 11i v2 (11.23.0505)
  • May 2005 Base Quality (QPKBASE) bundle
  • May 2005 Applications Quality (QPKAPPS) bundle
  • PHNE_32606 patch for servers with 64-bit HP-UX kernel

The following requirements apply when DB2 Version 9.5 is the database server on the metadata repository tier.

Table 16. Metadata repository tier requirements for DB2 Version 9.5 by operating system

Operating system Requirements
AIX 5.3 Technology Level 6 with Service Pack 2 and APAR IZ03063
HP-UX on Intel Itanium HP-UX 11i v2 (11.23.0505)
-May 2005 Base Quality (QPKBASE) bundle
-May 2005 Applications Quality (QPKAPPS) bundle
-PHCO_38637 - libc cumulative patch
HP-UX 11i v3 (11.31)
-PHCO_38658 - libc cumulative patch
Solaris 9 -Patches 111711-12 and 111712-12
-If raw devices are used, patch 122300-11
-Solaris 9 Kernel Update Patch 112233-01 or later to get the fix for patch 912041-01
Solaris 10 If raw devices are used, patch 125100-07
SUSE Linux Enterprise Server 10 SUSE Linux Enterprise Server 10 Service Pack 1

Services tier software requirements (Linux, UNIX)


WebSphere Application Server Version 6.0.2 fix pack 27 or a subsequent fix pack for this version is required for the services tier. IBM WebSphere Application Server can be installed with IBM InfoSphere Information Server or separately preinstalled. 32-bit and 64-bit versions of IBM WebSphere Application Server are supported and installed as shown in the following table.

Table 17. Installation options for IBM WebSphere Application Server Version 6.0.2.27

Operating system Installed with IBM Information Server Preinstalled supported
HP-UX on PA-RISC 32-bit 32-bit
HP-UX on Intel Itanium None 64-bit
IBM AIX 32-bit 32-bit or 64-bit
32-bit Red Hat Linux 32-bit 32-bit
64-bit Red Hat Linux None 64-bit
Solaris 32-bit 32-bit
32-bit SUSE Linux Enterprise Server 10 32-bit 32-bit
64-bit SUSE Linux Enterprise Server 10 None 64-bit

For Version 6.0.2.27 installation details, see www.ibm.com/support/docview.wss?uid=swg24018614.

64-bit IBM WebSphere Application Server packages are provided on the installation media for the following operating systems:

  • AIX
  • HP-UX on Intel Itanium
  • 64-bit Red Hat Linux
  • 64-bit SUSE Linux Enterprise Server 10

To use the 64-bit version of WebSphere Application Server, you must install it before you install InfoSphere Information Server. For details, see http://publib.boulder.ibm.com/infocenter/iisinfsv/v8r1/topic/com.ibm.swg.im.iis.
productization.iisinfsv.install.doc/topics/wsisinst_pln_64was.html
.

On AIX 6.1, the services tier requires 6100-00 Service Pack 4.

On AIX 5.3, the services tier requires maintenance package 5300-02.

IBM InfoSphere FastTrack

The metadata import process requires that at least one of the following components be installed on the services and engine tiers when you install IBM InfoSphere FastTrack on the client tier:

  • InfoSphere DataStage and IBM InfoSphere QualityStage
  • InfoSphere Information Analyzer

Engine tier software requirements (Linux, UNIX)


At least one of the following compilers is required for InfoSphere DataStage and IBM InfoSphere QualityStage when using the parallel canvas. The compilers must be installed on the computer where you install the engine tier. When you install a compiler, ensure that all of the compiler packages are installed.

Table 18. Required C++ compilers and runtime libraries

Operating system C++ compilers Runtime components and additional requirements
- 64-bit AIX 5.3
- 64-bit AIX 6.1
- May 2008 XL C/C++ Enterprise Edition V8.0 for AIX PTF, Reference #4019338
- August 2008 XL C/C++ Enterprise Edition V9.0 for AIX, Reference #4020144
- October 2008 XL C/C++ Enterprise Edition V10.1 for AIX, Reference #4021392
The runtime libraries are installed with the operating system.
HP-UX on PA-RISC aCC: HP ANSI C++ B3910B A.03.85 The runtime libraries are installed with the operating system.
- 64-bit HP-UX 11i v2 on Intel Itanium
- 64-bit HP-UX 11i v3 on Intel Itanium
-6.16 aCC: HP C/aC++ B3910B A.06.14
-6.16 aCC: HP C/aC++ B3910B A.06.20
The runtime libraries are installed with the operating system.
32-bit Red Hat Enterprise Linux 4 Server gcc 3.4 The runtime libraries are installed with the operating system.
64-bit Red Hat Enterprise Linux 4 Server gcc 3.4.6 Available on the Red Hat Linux installation media: glibc-devel-2.3.4-2.25.i386.rpm.
32-bit and 64-bit Red Hat Enterprise Linux 5 Advanced Platform gcc 4.1.2 The runtime libraries are installed with the operating system.
- 64-bit Solaris 9
- 64-bit Solaris 10
Sun Studio 10, 11 or 12 The runtime libraries are installed with the operating system.
32-bit and 64-bit SUSE Linux Enterprise Server 10 gcc 4.1.2 The runtime libraries are installed with the operating system.

Networking requirements (Linux, UNIX


The client, metadata repository, services, and engine tiers must be able to communicate with each other over the network on all ports that are used by the software.

Memory requirements (Linux, UNIX)


  • The minimum amount of memory for installing only one tier on a computer is 4 GB.
  • The minimum amount of memory for installing more than one tier on the same computer is 6 GB.

Operational memory requirements depend on the type of processing, the volume of parallel processing, the size and number of simultaneously running InfoSphere DataStage and IBM InfoSphere QualityStage jobs, and the memory requirements of the operating system and other applications (such as relational databases).

Evaluate the following factors to determine the memory requirements for your system:

  • Other software on the same server
  • Performance requirements
  • Size and complexity of your configuration
  • Extent of activity and the number of concurrent clients that access your system

Minimum disk space requirements (Linux, UNIX)


Important: These installation disk space requirements are the minimum requirements for installation. Operational requirements are significantly larger than these minimum installation disk space requirements.

The installation of IBM InfoSphere Information Server requires the following minimum disk space:

  • 1.3 GB for IBM WebSphere Application Server
  • 675 MB for DB2
  • 1.4 GB for IBM InfoSphere Information Server product components
  • 2.5 GB for the metadata repository database
  • 1 GB for the InfoSphere Information Analyzer analysis database
  • 2 GB of temporary space during the installation (HP-UX on PA-RISC requires 2.3 GB)

Note: Your system's temporary directory requires 1 GB of available disk space during installation, even when you specify an alternate location for the IBM InfoSphere Information Server installation program to use for temporary storage during installation.

Table 19. Minimum disk space requirements for the metadata repository tier installation

Metadata repository components Minimum disk space
DB2 DB2: 675 MB
db2inst1 home directory: 200 MB
dasusr home directory: 20 MB
Metadata repository database DB2: 2.5 GB
Oracle: 1 GB
InfoSphere Information Analyzer analysis database 1 GB

Table 20. Minimum disk space requirements for the services tier installation

Services components Minimum disk space
IBM WebSphere Application Server 1.3 GB
IBM InfoSphere Information Server product components 310 MB

Table 21. Minimum disk space requirements for the engine tier installation

Engine component Minimum disk space
IBM Information Server product components 700 MB

Table 22. Disk space requirements for the documentation installation

Documentation component Disk space
PDF documentation 400 MB


Cross reference information
Segment Product Component Platform Version Edition
Information Management InfoSphere FastTrack IBM Information Server Business Glossary Anywhere AIX, HP-UX, Linux, Solaris, Windows 8.1
Information Management InfoSphere Business Glossary InfoSphere Business Glossary Client for Eclipse AIX, HP-UX, Linux, Solaris, Windows 8.1
Information Management InfoSphere Metadata Workbench InfoSphere Business Glossary Client for Eclipse AIX, HP-UX, Linux, Solaris, Windows 8.1
Information Management InfoSphere DataStage InfoSphere Business Glossary Client for Eclipse AIX, HP-UX, Linux, Solaris, Windows 8.1
Information Management InfoSphere QualityStage InfoSphere Business Glossary Client for Eclipse AIX, HP-UX, Linux, Solaris, Windows 8.1
Information Management InfoSphere Information Analyzer InfoSphere Business Glossary Client for Eclipse AIX, HP-UX, Linux, Solaris, Windows 8.1
Information Management InfoSphere Information Services Director InfoSphere Business Glossary Client for Eclipse AIX, HP-UX, Linux, Solaris, Windows 8.1
Information Management InfoSphere Business Glossary InfoSphere Business Glossary Client for Eclipse AIX, HP-UX, Linux, Solaris, Windows 8.1.1
Information Management InfoSphere Business Glossary InfoSphere Business Glossary Client for Eclipse Windows 8.1.2

Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

InfoSphere Information Server

Software version:

8.1

Operating system(s):

AIX, HP-UX, Linux, Solaris, Windows

Reference #:

1315971

Modified date:

2011-03-16

Translate my page

Machine Translation

Content navigation