IBM Support

Configuring E-mail Listener for Maximo

Question & Answer


Question

Here are some tips on how to configure the e-mail listener in Maximo.

Cause

[ERROR] Failed to execute e-mail listener for
cron task LSNRCRON and cron instance LSNR602.
javax.mail.AuthenticationFailedException: Logon failure: unknown user
name or bad password.
at com.sun.mail.pop3.POP3Store.protocolConnect(POP3Store.java:104)
at javax.mail.Service.connect(Service.java:233)
at javax.mail.Service.connect(Service.java:134)
at javax.mail.Service.connect(Service.java:86)
at
psdi.common.emailstner.EmailListnerTask.readMessagesFromMailServer(Email
ListnerTask.java:347)
at
psdi.common.emailstner.EmailListnerTask.performTask(EmailListnerTask.jav
a:139)
at
psdi.common.emailstner.EmailListnerCron.cronAction(EmailListnerCron.java
:47)
at
psdi.server.CronTaskManager$CronThread.run(CronTaskManager.java:1240)

Answer

Here are some more tips for you to do troubleshooting when no ticket could be created under your configuration.

Under the correct setting from E-mail Listener Configuration, you still need to ensure the connection between Maximo application server and your mail server. A tool can help for the testing, <Maximo directory>\tools\maximo\internal\testemail.bat , it is executed under Windows command prompt.

TestEmail <host> <port> <user> <password> <protocol> <debug (true/false)>

Below is an example, please note that the Maximo application server should be running when you execute this command.


D:\Maximo\tools\maximo\internal>testemail ibmmaxsupport 110 maximo1 maximo pop3 true
** Email test: Connected to e-mail accountmaximo1

DEBUG: getProvider() returning javax.mail.Provider[STORE,pop3,com.sun.mail.pop3.POP3Store,Sun Microsystems, Inc]
POP3: connecting to host "ibmmaxsupport", port 110
S: +OK CMailServer 4.0 POP3 Service Ready
C: USER maximo1
S: +OK welcome here
C: PASS maximo
S: +OK
C: STAT
S: +OK 0 0
** Email test: opened folder INBOX
** Email test: You have no messages
C: QUIT
S: +OK bye
**Email test: Disconnected from account

If any error shows up in the outcome of this testing, please contact your Mail Administrator. You should have this running correctly before configuring the E-mail Listener.

[{"Product":{"code":"SSMLXR","label":"Tivoli Service Desk"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Maximo Service Desk","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"6.2.7;6.2.8;7.1.1;7.5","Edition":"All Editions","Line of Business":{"code":"LOB59","label":"Sustainability Software"}},{"Product":{"code":"SS6HJK","label":"Tivoli Service Request Manager"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":" ","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}},{"Product":{"code":"SSLKTY","label":"Maximo Asset Management for IT"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":" ","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
17 June 2018

UID

swg21308414