Dealing with CKR1400 MESSAGE - Running on an unsupported version z/OS x.y.z

Technote (troubleshooting)


Problem(Abstract)

While zSecure Admin or zSecure Audit can be running at a level lower than an operating system at a higher level, zSecure is unable make use of the new features of the z/OS and new RACF segments so an error message is displayed.

Symptom

Message CKR1400 04 Running on an unsupported version xx.yy.zz of z/OS, results are unpredictable - please upgrade

or similar mismatch of releases with zSecure lower than z/OS

Cause

The zSecure suite of products provides advanced use of the features available on the operating system it is written for, and those previous. It cannot make full use of services, features and upgrades (such as new classes and segments within RACF) of a release of z/OS later than its level. At this point, to avoid confusion as to why newer facilities aren't in use, the diagnostic message is written. To ensure it is not overlooked in the message stream, it assigns a return code of 4 (RC=04).

Environment

multiple levels of z/OS

Diagnosing the problem

Locate the message in the SYSPRINT message stream

Resolving the problem

After applying the PTF (See APAR OA28679) you can use the SUPPRESS MSG=1400 command (either in PREFACE or in the default set of commands issued for all jobs) to suppress the CKR1400 message and its resulting return code setting of 4. This will return the job to return code 0 unless other errors occur.

This APAR is not required for releases 1.11 and above.

As of zSecure Release 1.12, it is also possible to specify NOWARNING on the OPTION statement as shown in the User Guide:
NOWARNING
Reset the return code to 0 when warning messages have been issued. If the
internal return code is set to 4 or less as a result of warning messages, the
return code is reset to 0 at the end of the CARLa run. This option is only valid
on the OPTION command.


Cross reference information
Segment Product Component Platform Version Edition
Security IBM Security zSecure Audit Not Applicable z/OS 1.13.0, 1.13.1, 1.12
Security IBM Security zSecure Audit for Top Secret Not Applicable z/OS 1.13.0, 1.13.1, 1.12 All Editions
Security IBM Security zSecure Audit for ACF2 zAudit ACF2 z/OS 1.13.0, 1.13.1, 1.12 All Editions
Security IBM Security zSecure Audit for ACF2 zAudit ACF2 z/OS 1.10, 1.11 All Editions

Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

IBM Security zSecure Admin
zSecure Admin

Software version:

1.12, 1.13.0, 1.13.1

Operating system(s):

z/OS

Software edition:

Enterprise

Reference #:

1307304

Modified date:

2013-07-09

Translate my page

Machine Translation

Content navigation