Question & Answer
Question
LDAP Troubleshooting Multipart Document - When Maximo is not able to authenticate using LDAP, how can the issue be discovered and resolved?
Cause
Enhanced Documentation
Answer
The flow chart below describes an overview of the login process associated with Maximo Asset Management. This flowchart applies regardless of the authentication mechanism. Each of the main steps centered under the initial access box has an associated document that details that portion of the functionality. At the bottom of this flow chart are links to the associated documents. Each associated document contains a link to return to this master document.
Click on any step in the flow chart to link to an associated document or scroll to the bottom to see steps and troubleshooting.
Steps to login
1) User enters URL to Maximo to initiate the login process
2) JEE Server receives request and checks to see if JEE security enabled
3) JEE Server checks to see if URL entered points to a protected resource
4) JEE Server notifies local client browser to generate a login dialog
5) Local client browser generates login dialog and user enters credentials
6) LDAP server authenticates user
7) JEE Server checks user role mapping for member of authorized group
8) JEE Server passes authenticated user to Maximo
9) Maximo checks MAXUSER.LOGINID column for matching username
10) Maximo checks user for configured Start Center
11) Maximo completes the login process
Troubleshooting
A) User cannot authenticate
B) User gets a browser 401 error
C) User gets a browser 403 error
D User gets a Maximo error page "the user <username> is not authorized to use this application"
E User gets a Maximo error page "the user unauthenticated user is not authorized to use this application"
F) User gets a Maximo error page "the user <username> does not have a Start Center configured"
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Document Information
Modified date:
13 April 2021
UID
swg21303950