IBM Support

Storage-agent and library-client compatibility with an IBM Spectrum Protect server

Technote (FAQ)


What are the levels of storage agents and library clients that are compatible with V6.1, V6.2, V6.3 and V7.1 IBM® Spectrum Protect servers that are configured as library managers?


Tip: Beginning with Version 7.1.3, IBM Tivoli Storage Manager is now IBM Spectrum Protect.
Some applications such as the software fulfillment systems and IBM License Metric Tool use the new product name.
However, the software and its product documentation continue to use the Tivoli Storage Manager product name. To learn more about the rebranding transition, see Tivoli Storage Manager branding transition to IBM Spectrum Protect.

For lists of storage agents and library clients that are compatible with IBM Spectrum Protect servers that are configured as library managers, see the following table.

IBM Spectrum Protect Server
(Library Manager) Version
IBM Spectrum Protect
Library Client and Storage Agent Versions
7.1, 6.3, and 6.2
6.3, 6.2, 6.1
6.2, 6.1
    1. For any given version of the IBM Spectrum Protect server (library manager), the library client and storage agent must be at an equal or earlier modification level. For example, in V.R.M.F, M is the modification level.
    2. The server and storage agent code level for the IBM Spectrum Protect V6.4 release is V6.3.3. The V6.3 information in this table applies to V6.4.
  • In cases where a storage agent uses an IBM Spectrum Protect server that is also a library client, the storage agent must meet the compatibility requirements for both the library manager and the library client.
  • A problem might occur between an IBM Spectrum Protect server and a library client or storage agent that is not at the latest modification level for that version and release of the server. To receive a fix for a problem, you might have to upgrade the storage agent or library client to the server's modification level.
  • New function that is available in a specific version, release, and modification level of the server is not supported with earlier version, release, and modification levels of the storage agent.
  • Only V6.2 or later storage agents can use LAN-free data movement to access storage pools that contain data that was deduplicated by clients. V6.1 storage agents or earlier cannot use LAN-free data movement to access these storage pools. Using a V6.1 storage agent or earlier to access a storage pool that contains client side deduplicated data causes restore operations and retrieve operations to go over the LAN.
  • To prevent problems unloading and returning tape volumes back to the IBM Spectrum Protect-controlled library, upgrade the IBM Spectrum Protect server library client to V. See APAR IC98448.

Product Alias/Synonym

IBM Spectrum Protect

Document information

More support for: Tivoli Storage Manager

Software version: 6.1, 6.2, 6.3, 7.1

Operating system(s): AIX, HP-UX, Linux, Solaris, Windows

Software edition: Enterprise

Reference #: 1302789

Modified date: 29 March 2012