Collecting Data: Lotus Quickr Connectors

Technote (FAQ)


Question

What data can be collected to troubleshoot issues with Lotus Quickr Connectors?

Answer

In most cases, capturing data from the DITrace executable file that comes with Connectors, along with using a network capture tool like the Fiddler network capture tool, can be useful in problem determination. In a default Connectors installation, DITrace data is only collected when using the Windows Explorer Connectors and not when using Notes Connectors. Fiddler captures data in both Windows Explorer Connectors and Notes Connectors.

Use the steps below to collect data for the Connectors in question, Windows Explorer or Notes Connector, and to remove any ID or password information from the traces. Occasionally, Web Services server-side debugging is required; steps for that debug are also below. Once the data is collected, you can submit the diagnostic information to IBM support.




Collecting Data using Windows Explorer Connectors

If the problem is experienced in (a) Windows Explorer Connectors only or (b) both Windows Explorer Connectors and Notes Connectors, then perform the following steps to collect data using Fiddler and DITrace:

1. Install the Fiddler network capture tool on your workstation.

2. Close all browsers on your workstation, so as to not capture any web traffic from them in Fiddler that could complicate reviewing the data collected.

3. Start the DITrace.exe executable on the workstation experiencing the issue in Connectors.

By default, this file will be located in the following directory:
  • pre-8.5 Connectors clients = C:\Program Files\IBM\Lotus Quickr connectors
  • 8.5 Connectors clients = C:\Program Files\IBM\Places Connectors

4. Start Fiddler on your workstation, and clear all traffic recorded in it using the "Remove all" option (see screen capture below):



NOTE: If the server is accessed via SSL, then please enable the "Capture HTTPS CONNECTs" and "Decrypt HTTPS traffic" options under "Tools -> Fiddler Options -> HTTPS" so that the data is readable by support.

5. Open Connectors in Windows Explorer and recreate the issue.

6. Save the Fiddler log as a ".saz" file.

7. Save the output from DITrace to a text file by clicking "File --> Save to file...". The default file name is qc_trace.log.

8. Perform the steps in the "Removing ID/password information from Fiddler Traces" section below.

9. Send in the two files from Steps 6 and 7 for review.



Collecting Data using Notes Connectors

If the issue is specific to Notes Connectors, then debugging information can still be collected in DITrace by performing the following modifications:

1. Install the Fiddler network capture tool on your workstation.

2. Close all browsers on your workstation, so as to not capture any web traffic from them in Fiddler that could complicate reviewing the data collected.

3. Close the Notes client.

4. Open the file "<notes install location>\data\workspace\.config\rcpinstall.properties" and add these three lines to this file:
  • com.ibm.documents.connector.level=FINEST
  • com.ibm.quickr.client.level=FINEST
  • com.ibm.quickr.client.common.notes.level=FINEST

5. Save and close the file.

6. Start Fiddler on the same workstation and clear all traffic recorded in it using the "Remove all" option (see screen capture below):



NOTE: If the server is accessed using SSL, then enable the "Capture HTTPS CONNECTs" and "Decrypt HTTPS traffic" options under "Tools -> Fiddler Options -> HTTPS" so that the data is readable by support.

7. Restart the Notes client.

8. Start the DITrace.exe executable on the workstation experiencing the issue in Connectors. By default, this file will be located in the following directory:
  • pre-8.5 Connectors clients = C:\Program Files\IBM\Lotus Quickr connectors
  • 8.5 Connectors clients = C:\Program Files\IBM\Places Connectors

9. Open Connectors in Notes and recreate the issue.

10. Save the Fiddler log as a ".saz" file.

11. Save the output from DITrace to a text file by clicking "File --> Save to file...". The default file name is qc_trace.log. The DITrace log files can be found in the "<notes install location>\Data\workspace\logs" directory. Compress (zip up) the contents of this directory.

12. Perform the steps in the "Removing ID/password information from Fiddler Traces" section below

13. Send in the two files from Steps 10 and 11 for review.



Removing ID/password information from Fiddler Traces

Once a Fiddler log has been created and saved, it might contain the user's ID and password used during the recreation of the issue. To remove this information prior to sending the files to IBM Support, perform the following steps:

1. Extract the .saz file's contents using a file compression or archiving tool such as WinZip or WinRAR. (A Fiddler .saz file is basically a .zip file.)

2. Examine the .saz file's contents. It contains a folder called "raw" and a file called "index.html". Inside the "raw" folder, you will see a listing of files such as:
    0000_c.txt
    0000_s.txt
    0000_m.xml
    0001_c.txt
    0001_s.txt
    0001_m.xml

All files with "_c" in their file name represent the client requests.

3. Open each of the "_c" files and look for instances of the Authorization header such as follows:
    Authorization: Basic adfadfwer234ewkj23423
    The string like "adfadfwer234ewkj23423" is a Base 64 encoding of the user's ID and password.

4. To remove this information, replace each instance of the "adfadfwer234ewkj23423" string with a placeholder like "xxxxxxxxxxxxxxxxxxxxxx". Save these changes.

5. After saving your changes, re-zip the "raw" folder and the index.html file back into a single .zip file and then rename the file to have a .saz extension.

6. To confirm that the above steps have been performed correctly, reopen the new .saz file with Fiddler and verify the file opens properly.



Web Services server-side debugging for Connectors

Occasionally, IBM Support will request that server-side Web Services debugging be collected for Connectors issues. If this is the case, enter the following commands on the Domino server console to enable this debugging in the Lotus Quickr for Domino server's console.log file:

- start console
- set config console_log_enabled=1
- set config Console_LogLevel=2
- set config debug_threadid=1
- set config QuickplaceWebServicesLogging=5
- restart task http

What to do next?
When providing the above data collected while recreating the issue, also provide as much of the following additional information as possible:

  1. The version of Domino on the server (include any hotfixes and fixpacks)
  2. The version of Quickr on the server (include any fixpacks)
  3. The version of Quickr Connectors (include specific fixpack version)
  4. The operating system version on which Domino/Quickr is running
  5. The operating system version on which the Connectors client is running
  6. A detailed description of the issue; include any error messages verbatim and screen captures if possible
  7. If applicable and possible, step-by-step instructions for reproducing the issue
  8. Does the issue occur for all users, some users, or one user? If only one user is reporting the issue, please have two to three others test to see if they experience the same issue.
  9. Does the issue occur in all places, some places, or one place? If only one place is experiencing the issue, please provide a copy of the place files in question for internal testing.
  10. Did this work at one time in the past? If so, are you aware of anything that might have changed around the time the problem began to occur?

Once you have collected the preceding files and information, you can begin analyzing the data or submit the diagnostic information to IBM support. Submitting data to IBM requires that a PMR be opened, if not already.

For more information about troubleshooting issues with Lotus Quickr Connectors, refer to the "Troubleshooting the IBM Lotus Domino Quickr Connectors" wiki article.



    Cross reference information
    Segment Product Component Platform Version Edition
    Organizational Productivity- Portals & Collaboration Lotus Quickr for WebSphere Portal Connectors Windows 8.5, 8.1.1, 8.1

Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

Lotus Quickr for Domino
Connectors

Software version:

8.2, 8.5

Operating system(s):

AIX, Windows, i5/OS

Reference #:

1299033

Modified date:

2013-02-20

Translate my page

Machine Translation

Content navigation