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"This feature has not been enabled" error while downloading Sametime Connect 8.0

 Technote (troubleshooting)
 
 
Problem
You use a web browser to download LotusĀ® SametimeĀ® Connect client version 8.0 from the Sametime server's stcenter.nsf home page. When you click the download link, you receive the error:


This feature has not been enabled.





This error occurs after the system administrator implements the Sametime Information Center instructions: Making the client installation files available for download
 
Symptom
Users cannot download the 8.0 Connect client from the link provided in the server's home page (stcenter.nsf).
 
Cause
The Network client package (C14F3ML.zip) contains an extended directory structure. When extracting the contents of this zip package and selecting the "network-install" directory as the target folder, the path documented as an example would not be correct.


Using C:\lotus\domino as the root folder for the Sametime server installation and following the Information Center instructions, when you extract the archive file to the "network-install" folder, the files are incorrectly placed in the following location:


C:\lotus\Domino\data\domino\html\sametime\network-install
\SametimeConnectNetworkInstall\network-install


The correct path is:


C:\lotus\Domino\data\domino\html\sametime
\network-install\
 
Resolving the problem
Step 1: Relocate the files to the correct path
You must move the files to the correct file system path.


  1. Navigate to the current (incorrect) location of the "network-install" folder using tools provided by your server operating system.
    For example:
    Windows
    C:\lotus\Domino\data\domino\html\sametime\network-install
    \SametimeConnectNetworkInstall\network-install


  2. From this location, cut the following folders:

    applet
    bin
    install
    install.mac
    nci.js




  3. Navigate to the correct location.
    For example:
    Windows
    C:\lotus\Domino\data\domino\html\sametime\network-install\


  4. Paste the folders that were cut. Replace any duplicate files.


  5. The files should appear as follows. Note the file system path below:


Step 2: Verify that the installer URL information is correct and create the archive
Verify that the file location specified in the steps above is correct for the installer URL and run the archive creator. These steps are documented in the Sametime Information Center topic: Making the client installation files available for download

For your convenience, a summary of those steps is provided below:

  1. Open the \domino\html\sametime\network-install\applet\download.properties file in a text editor.

  2. Set the value of the installer.root.base property to match the correct URL for the network-install directory on your Lotus Sametime server.

    For example, if your Sametime server host name is stserver.com:
    installer.root.base=http://stserver.com/sametime/network-install

  3. Save the changes.

  4. Generate the installer archive zips.

The ArchiveCreator scripts create platform specific installer zip files. These zip files only include the base installer with the Expediter/Eclipse platform and the install manifest which can be customized for your environment. This allows the user to download the zip file, extract it, and run the installer which provisions the Lotus Sametime features from the update site included with the network-install directory. The zip files are approximately 25 MB instead of over 200 MB as they are on the CD.


For Windows and Unix
Open a console window to the \domino\html\sametime\network-install\bin directory
Run the ArchiveCreator tool (ArchiveCreator.bat for Windows, ArchiveCreator.sh for UNIX).

For i5/OS
Run the following commands:
    QSH
    cd /<server_data_directory>/domino/html/sametime/network-install/bin
    ArchiveCreator_i5OS.sh
    Press F3 to Exit QSH.

Note: The network client installer does not currently support installing over the network when the Domino HTTP server has been configured to use SSL with a self-signed test certificate.
 
 
 

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Document information
 Product categories:
 Software
 Organizational Productivity, Portals & Collaboration
 Real-time & Team Collaboration
 Lotus Sametime
 Connect client
 Operating system(s):
  Linux, Mac OS X, Windows
 Software version:
  8.0
 Software edition:
  All Editions
 Reference #:
  1298845
 IBM Group:
 Software Group
 Modified date:
 2008-08-21

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