IBM Support

Domino console messages appear as numbers instead of text in UNIX or Windows

Technote (troubleshooting)


Problem

You install a Lotus Domino® server on a UNIX® platform, then start the server. When you view the Domino console, you see numbers instead of the standard initialization messages.

Example:

    00:13, ,
    00:14

    /local/notesdata/server.id

    [date] 11:07:27 AM  09:3A
    [date] 11:07:27 AM  09:3B
    [date] 11:07:27 AM  33:78
    [date] 11:07:28 AM  13:6F
    [date] 11:07:28 AM  13:6B
    [date] 11:07:28 AM
    [date] 11:07:28 AM
    [date] 11:07:28 AM  33:02
    [date] 11:07:28 AM  33:02
    [date] 11:07:29 AM  33:25
    [date] 11:07:29 AM  33:02
    [date] 11:07:29 AM  33:0E
    [date] 11:07:29 AM  33:02
    [date] 11:07:29 AM  33:14
    [date] 11:07:29 AM  33:71
    [date] 11:07:29 AM  33:76: 05:01
    [date] 11:07:29 AM  33:16: 05:01
    [date] 11:07:29 AM  34:35
    [date] 11:07:29 AM  33:17

    ConvertZoneToText: Warning Time Zone 3 not found!
    ConvertZoneToText: Warning Time Zone 3 not found!

    [date] 11:07:29 AM  HTTP Server: Cannot load resource file. Exiting
    [date] 11:07:29 AM  33:21
    [date] 11:07:29 AM  03:61
    [date] 11:07:29 AM  33:16: 05:01

Cause

In this case, the Domino server could not locate the strings.res file. Therefore, the server could not render the messageIDs as text on the console.


Resolving the problem

The default directory in which Domino looks for the strings.res file in the English version is located at /opt/lotus/notes/latest/<arch>/res/<lang>/strings.res, where <arch> is the architecture of the operating system on which you are running (sunspa, ibmpow, or hppa), and <lang> corresponds to the operating system default locale/language.


In the English version, <lang> is located on "C" by default. To correct the problem, make sure the strings.res file exists in the expected location.

Case study:
The administrator installed a Domino 8.0.1 server in English on a Linux SUSE 10 64-bit operating system in English. After this, the "C" directory did not exist in the path above. The only directory available after the .../res was pt_BR.UTF-8 (a language-specific directory) and the strings.res file was located in this directory. This directory is created when the operating system is set up as language-specific, in this case, Brazilian Portuguese.

Although the original install was in English, the Brazilian Portugues directory was created because the administrator ran the Domino setup remotely. The machine used for the remote session was a Linux client in Brazilian Portuguese. When the administrator ran the setup, the operating system applied the Brazilian Portuguese configuration from the client operating system to the server operating system.

The resolution for this case was to run the Domino setup again directly on the machine on which Domino was installed, instead of running setup remotely.

NOTE: Similar behavior can be seen in the Windows environment if the nstrings.dll file located in the Domino folder is damaged or missing.

Related information

Codes appear instead of console on Unix using Telnet
A simplified Chinese translation is available

Document information

More support for: IBM Domino
Server Tasks

Software version: 7.0, 8.0, 8.5

Operating system(s): Linux, Windows

Reference #: 1298729

Modified date: 21 April 2008


Translate this page: