AgentDisconnect error due to incompatible agent and console

Technote (troubleshooting)


When trying to run a step on the agent in IBM® Rational® Build Forge® iFix1 for 7.0.2 the operation fails with an AgentDisconnect error.


This is a known compatibility issue with the Build Forge 7.0.2-iFix1 Agent and older versions of the Management Console. For example, if using a 7.0.2-iFix1 Agent against a 7.0.1 (or older) console, then the reverse-compatibility issue will cause a sudden disconnection from the client.


Build Forge iFix1 for 7.0.2 Agent with 7.0.1 (or older) console.

Resolving the problem

Upgrade the Management Console to the same version of the Build Forge Agent to resolve the AgentDisconnect errors. Refer to technote 1254846 for details on obtaining the 7.x download.

Document information

More support for:

Rational Build Forge

Software version:

7.0.1, 7.0.2

Operating system(s):

AIX, Linux, Solaris, Windows

Software edition:

Enterprise, Express, Standard

Reference #:


Modified date:


Translate my page

Content navigation